Skip to content

← Actionable
High, CVSS 8.8

october/system arbitrary code execution

CVE-2021-32650GHSA-5hfj-r725-wpc4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (october/system 1.1.6, 1.0.473), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist october/system

    Affected
    >= 1.1.0, < 1.1.6< 1.0.473
    Fixed in
    1.1.6, 1.0.473

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2021-32650: 2.09% estimated exploitation activity in the next 30 days; percentile 81.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Assuming an attacker with access to the backend is able to execute PHP code by using the theme import feature. This will bypass the safe mode feature that prevents PHP execution in the CMS templates. Patches Issue has been patched in Build 473 and v1.1.6 Workarounds Apply https://github.com/octobercms/october/commit/167b592eed291ae1563c8fcc5b9b34a03a300f26 to your installation manually if you are unable to upgrade. References Credits to: • Sushi Yushi For more information If you have any questions or comments about this advisory: Email us at hello@octobercms.com

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-5hfj-r725-wpc4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-32650

Advisory: october/system arbitrary code execution
IDs: CVE-2021-32650, GHSA-5hfj-r725-wpc4
Record: https://patchnext.com/advisories/cve-2021-32650 (revision 1, source checked 26 Oct 2026, 14:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: october/system 1.1.6, 1.0.473. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist october/system: affected >= 1.1.0, < 1.1.6; < 1.0.473; fixed in 1.1.6, 1.0.473

## Suggested inspection (read-only)
- Packagist october/system: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on october/system.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5hfj-r725-wpc4 (GitHub-reviewed advisory GHSA-5hfj-r725-wpc4 lists affected ranges: Packagist october/system >=1.1.0 =0 <1.0.473)

Commands are suggestions: review each one before running it.

Loading voting…