Skip to content

← Actionable
High, CVSS 8.2Exploited · CISA KEV

Account Takeover in Octobercms

CVE-2021-32648GHSA-mxr5-mc97-63rc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (october/system 1.1.5, 1.0.472), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist october/system

    Affected
    < 1.0.472>= 1.1.1, < 1.1.5
    Fixed in
    1.1.5, 1.0.472

Sources

Severity and exploitation
Exploitation
Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
CVSS
8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N/E:H
EPSS
  • CVE-2021-32648: 91.12% estimated exploitation activity in the next 30 days; percentile 99.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An attacker can request an account password reset and then gain access to the account using a specially crafted request. - To exploit this vulnerability, an attacker must know the username of an administrator and have access to the password reset form. Patches - Issue has been patched in Build 472 and v1.1.5 - Shortened patch instructions Workarounds Apply https://github.com/octobercms/library/commit/016a297b1bec55d2e53bc889458ed2cb5c3e9374 and https://github.com/octobercms/library/commit/5bd1a28140b825baebe6becd4f7562299d3de3b9 to your installation manually if you are unable to upgrade. [Update 2022-01-20] Shortened patch instructions can be found here. Recommendations We recommend the following steps to make sure your server stays secure: - Keep server OS and system software up to date. - Keep October CMS software up to date. - Use a multi-factor authentication plugin. - Change the default backend URL or block public access to the backend area. - Include the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-mxr5-mc97-63rc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-32648

Advisory: Account Takeover in Octobercms
IDs: CVE-2021-32648, GHSA-mxr5-mc97-63rc
Record: https://patchnext.com/advisories/cve-2021-32648 (revision 1, source checked 26 Oct 2026, 14:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
Vendor response: Vendor fix available; fixed versions by package: october/system 1.1.5, 1.0.472. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist october/system: affected < 1.0.472; >= 1.1.1, < 1.1.5; fixed in 1.1.5, 1.0.472

## Suggested inspection (read-only)
- Packagist october/system: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on october/system.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2021-32648 to the Known Exploited Vulnerabilities catalog on 2022-01-18.)
- Verified: https://github.com/advisories/GHSA-mxr5-mc97-63rc (GitHub-reviewed advisory GHSA-mxr5-mc97-63rc lists affected ranges: Packagist october/system >=0 =1.1.1 <1.1.5)

Commands are suggestions: review each one before running it.

Loading voting…