Open Redirect
CVE-2021-32645GHSA-4r8q-gv9j-3xx6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (hyn/multi-tenant 5.7.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist hyn/multi-tenant
- Affected
- >= 5.6.0, < 5.7.2
- Fixed in
- 5.7.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4r8q-gv9j-3xx6 lists affected ranges: Packagist hyn/multi-tenant >=5.6.0 <5.7.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
- EPSS
- CVE-2021-32645: 1.02% estimated exploitation activity in the next 30 days; percentile 63.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact In some situations, it is possible to have open redirects where users can be redirected from your site to any other site using a specially crafted URL. This is only the case for installations where the default Hostname Identification is used and the environment uses tenants that have forcehttps set to true (default: false) Patches Version 5.7.2 contains the relevant patches to fix this bug. Stripping the URL from special characters to prevent specially crafted URL's from being redirected to. Workarounds There is a simple way to work around the security issue - Set the forcehttps to every tenant to false References https://nvd.nist.gov/vuln/detail/CVE-2018-11784 For more information If you have any questions or comments about this advisory: Contact us in Discord: https://tenancy.dev/chat
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4r8q-gv9j-3xx6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-32645 Advisory: Open Redirect IDs: CVE-2021-32645, GHSA-4r8q-gv9j-3xx6 Record: https://patchnext.com/advisories/cve-2021-32645 (revision 1, source checked 26 Oct 2026, 14:01 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: hyn/multi-tenant 5.7.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist hyn/multi-tenant: affected >= 5.6.0, < 5.7.2; fixed in 5.7.2 ## Suggested inspection (read-only) - Packagist hyn/multi-tenant: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on hyn/multi-tenant. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4r8q-gv9j-3xx6 (GitHub-reviewed advisory GHSA-4r8q-gv9j-3xx6 lists affected ranges: Packagist hyn/multi-tenant >=5.6.0 <5.7.2) Commands are suggestions: review each one before running it.
Loading voting…