Skip to content

← Actionable
High, CVSS 8.1amended

Reflected XSS when using flashMessages or languageDictionary

CVE-2021-32641GHSA-jr3j-whm4-9wwm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (auth0-lock 11.30.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2021-32641: 1.54% estimated exploitation activity in the next 30 days; percentile 74.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Overview Versions before and including 11.30.0 are vulnerable to reflected XSS. An attacker can execute arbitrary code when the library's - flashMessage feature is utilized and user input or data from URL parameters is incorporated into the flashMessage. - languageDictionary feature is utilized and user input or data from URL parameters is incorporated into the languageDictionary. Am I affected? You are affected by this vulnerability if you are using auth0-lock version 11.30.0 or lower and all of the following conditions apply: - You are utilizing flashMessage feature. - User input or data from URL parameters is incorporated into the flashMessage. An example of a vulnerable snippet where query parameters are used to populate the text property of a flashMessage. OR - You are utilizing languageDictionary feature. - User input or data from URL parameters is used in languageDictionary properties. An example of a vulnerable snippet where query parameters are used to populate the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-jr3j-whm4-9wwm

  2. Revision 1 · created ·

    Published from osv record GHSA-jr3j-whm4-9wwm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-32641

Advisory: Reflected XSS when using flashMessages or languageDictionary
IDs: CVE-2021-32641, GHSA-jr3j-whm4-9wwm
Record: https://patchnext.com/advisories/cve-2021-32641 (revision 2, source checked 26 Oct 2026, 12:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: auth0-lock 11.30.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm auth0-lock: affected < 11.30.1; fixed in 11.30.1

## Suggested inspection (read-only)
- `npm ls auth0-lock --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on auth0-lock.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-jr3j-whm4-9wwm (OSV record GHSA-jr3j-whm4-9wwm lists affected ranges: npm auth0-lock >=0 <11.30.1 (fixed))
- Verified: https://github.com/advisories/GHSA-jr3j-whm4-9wwm (GitHub-reviewed advisory GHSA-jr3j-whm4-9wwm lists affected ranges: npm auth0-lock >=0 <11.30.1)

Commands are suggestions: review each one before running it.

Loading voting…