Skip to content

← Actionable
Critical, CVSS 9.8

Deno's static imports inside dynamically imported modules do not adhere to permission checks

CVE-2021-32619GHSA-xpwj-7v8q-mcgj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (deno 1.10.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io deno

    Affected
    >= 1.5.0, <= 1.10.1
    Fixed in
    1.10.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2021-32619: 1.11% estimated exploitation activity in the next 30 days; percentile 66.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Modules that are dynamically imported through import() or new Worker might have been able to bypass network and file system permission checks when statically importing other modules. In Deno 1.5.x and 1.6.x only programs dynamically importing (especially transitively) untrusted code are affected. In Deno 1.7.x all programs importing (especially transitively) untrusted code are affected. In effect an attacker in control of a (possibly remote) module in a programs module graph has been able to, irrespective of permissions: 1. initiate GET requests to arbitrary URLs on the internet (including LAN) and possibly read (parts of) the contents of these resources. 2. check for existence of arbitrary paths on the file system, and possibly read (parts of) the contents of these files. In Deno 1.5.x (October 27th, 2020) and Deno 1.6.x (December 8th, 2020) the attacker module had to have been granted permissions to load dynamically through the network / fs read permission. Since Deno 1.7.x…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-xpwj-7v8q-mcgj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-32619

Advisory: Deno's static imports inside dynamically imported modules do not adhere to permission checks
IDs: CVE-2021-32619, GHSA-xpwj-7v8q-mcgj
Record: https://patchnext.com/advisories/cve-2021-32619 (revision 1, source checked 26 Oct 2026, 15:33 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: deno 1.10.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io deno: affected >= 1.5.0, <= 1.10.1; fixed in 1.10.2

## Suggested inspection (read-only)
- crates.io deno: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on deno.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-xpwj-7v8q-mcgj (GitHub-reviewed advisory GHSA-xpwj-7v8q-mcgj lists affected ranges: crates.io deno >=1.5.0 <=1.10.1)

Commands are suggestions: review each one before running it.

Loading voting…