Moodle Information Disclosure vulnerability
CVE-2021-32473GHSA-wx87-h539-4775
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (moodle/moodle 3.10.4, 3.9.7, 3.8.9, 3.5.18), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist moodle/moodle
- Affected
- >= 3.5, < 3.5.18>= 3.8, < 3.8.9>= 3.9, < 3.9.7>= 3.10, < 3.10.4
- Fixed in
- 3.10.4, 3.5.18, 3.9.7, 3.8.9
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wx87-h539-4775 lists affected ranges: Packagist moodle/moodle >=3.5 =3.8 =3.9 =3.10 <3.10.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2021-32473: 1.03% estimated exploitation activity in the next 30 days; percentile 63.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
It was possible for a student to view their quiz grade before it had been released, using a quiz web service. Moodle 3.10 to 3.10.3, 3.9 to 3.9.6, 3.8 to 3.8.8, 3.5 to 3.5.17 and earlier unsupported versions are affected
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-wx87-h539-4775
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-32473 Advisory: Moodle Information Disclosure vulnerability IDs: CVE-2021-32473, GHSA-wx87-h539-4775 Record: https://patchnext.com/advisories/cve-2021-32473 (revision 1, source checked 26 Oct 2026, 14:19 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: moodle/moodle 3.10.4, 3.9.7, 3.8.9, 3.5.18. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist moodle/moodle: affected >= 3.5, < 3.5.18; >= 3.8, < 3.8.9; >= 3.9, < 3.9.7; >= 3.10, < 3.10.4; fixed in 3.10.4, 3.5.18, 3.9.7, 3.8.9 ## Suggested inspection (read-only) - Packagist moodle/moodle: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on moodle/moodle. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-wx87-h539-4775 (GitHub-reviewed advisory GHSA-wx87-h539-4775 lists affected ranges: Packagist moodle/moodle >=3.5 =3.8 =3.9 =3.10 <3.10.4) Commands are suggestions: review each one before running it.
Loading voting…