MongoDB Driver may publish events containing authentication-related data
CVE-2021-32050GHSA-vxvm-qww3-2fh7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mongodb/mongodb 1.9.2; mongodb 5.8.0, 4.17.0, 3.6.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist mongodb/mongodb
- Affected
- >= 1.0.0, < 1.9.2
- Fixed in
- 1.9.2
npm mongodb
- Affected
- >= 3.6.0, < 3.6.10>= 4.0.0, < 4.17.0>= 5.0.0, < 5.8.0
- Fixed in
- 5.8.0, 4.17.0, 3.6.10
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vxvm-qww3-2fh7 lists affected ranges: Packagist mongodb/mongodb >=1.0.0 =3.6.0 =4.0.0 =5.0.0 <5.8.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.2 · CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:U/C:H/I:N/A:N
- EPSS
- CVE-2021-32050: 0.65% estimated exploitation activity in the next 30 days; percentile 51.03 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Some MongoDB Drivers may erroneously publish events containing authentication-related data to a command listener configured by an application. The published events may contain security-sensitive data when specific authentication-related commands are executed. Without due care, an application may inadvertently expose this sensitive information, e.g., by writing it to a log file. This issue only arises if an application enables the command listener feature (this is not enabled by default). This issue affects the MongoDB C Driver 1.0.0 prior to 1.17.7, MongoDB PHP Driver 1.0.0 prior to 1.9.2, MongoDB Swift Driver 1.0.0 prior to 1.1.1, MongoDB Node.js Driver 3.6 prior to 3.6.10, MongoDB Node.js Driver 4.0 prior to 4.17.0 and MongoDB Node.js Driver 5.0 prior to 5.8.0. This issue also affects users of the MongoDB C++ Driver dependent on the C driver 1.0.0 prior to 1.17.7 (C++ driver prior to 3.7.0).
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vxvm-qww3-2fh7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-32050 Advisory: MongoDB Driver may publish events containing authentication-related data IDs: CVE-2021-32050, GHSA-vxvm-qww3-2fh7 Record: https://patchnext.com/advisories/cve-2021-32050 (revision 1, source checked 26 Oct 2026, 12:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mongodb/mongodb 1.9.2; mongodb 5.8.0, 4.17.0, 3.6.10. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist mongodb/mongodb: affected >= 1.0.0, < 1.9.2; fixed in 1.9.2 - npm mongodb: affected >= 3.6.0, < 3.6.10; >= 4.0.0, < 4.17.0; >= 5.0.0, < 5.8.0; fixed in 5.8.0, 4.17.0, 3.6.10 ## Suggested inspection (read-only) - Packagist mongodb/mongodb: check the installed version with your package manager. - `npm ls mongodb --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mongodb/mongodb, mongodb. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vxvm-qww3-2fh7 (GitHub-reviewed advisory GHSA-vxvm-qww3-2fh7 lists affected ranges: Packagist mongodb/mongodb >=1.0.0 =3.6.0 =4.0.0 =5.0.0 <5.8.0) Commands are suggestions: review each one before running it.
Loading voting…