Skip to content

← Actionable
High, CVSS 8.7

Rancher Privilege escalation vulnerability via malicious "Connection" header

CVE-2021-31999GHSA-pvxj-25m6-7vqr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/rancher/rancher 2.5.9, 2.4.16), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2021-31999: 1.05% estimated exploitation activity in the next 30 days; percentile 64.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A vulnerability was discovered in Rancher 2.0.0 through the aforementioned patched versions, where a malicious Rancher user could craft an API request directed at the proxy for the Kubernetes API of a managed cluster to gain access to information they do not have access to. This is done by passing the "Impersonate-User" or "Impersonate-Group" header in the Connection header, which is then correctly removed by the proxy. At this point, instead of impersonating the user and their permissions, the request will act as if it was from the Rancher management server and incorrectly return the information. The vulnerability is limited to valid Rancher users with some level of permissions on the cluster. There is not a direct mitigation besides upgrading to the patched Rancher versions.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-pvxj-25m6-7vqr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-31999

Advisory: Rancher Privilege escalation vulnerability via malicious "Connection" header
IDs: CVE-2021-31999, GHSA-pvxj-25m6-7vqr
Record: https://patchnext.com/advisories/cve-2021-31999 (revision 1, source checked 26 Oct 2026, 15:04 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/rancher/rancher 2.5.9, 2.4.16. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/rancher/rancher: affected >= 2.0.0, < 2.4.16; >= 2.5.0, < 2.5.9; fixed in 2.4.16, 2.5.9

## Suggested inspection (read-only)
- Go github.com/rancher/rancher: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/rancher/rancher.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-pvxj-25m6-7vqr (GitHub-reviewed advisory GHSA-pvxj-25m6-7vqr lists affected ranges: Go github.com/rancher/rancher >=2.0.0 =2.5.0 <2.5.9)

Commands are suggestions: review each one before running it.

Loading voting…