Pgsync Contains Cleartext Transmission of Sensitive Information
CVE-2021-31671GHSA-72rj-36qc-47g7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pgsync 0.6.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems pgsync
- Affected
- < 0.6.7
- Fixed in
- 0.6.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-72rj-36qc-47g7 lists affected ranges: RubyGems pgsync >=0 <0.6.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2021-31671: 0.73% estimated exploitation activity in the next 30 days; percentile 54.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
pgsync before 0.6.7 is affected by Information Disclosure of sensitive information. Syncing the schema with the --schema-first and --schema-only options is mishandled. For example, the sslmode connection parameter may be lost, which means that SSL would not be used.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-72rj-36qc-47g7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-31671 Advisory: Pgsync Contains Cleartext Transmission of Sensitive Information IDs: CVE-2021-31671, GHSA-72rj-36qc-47g7 Record: https://patchnext.com/advisories/cve-2021-31671 (revision 1, source checked 26 Oct 2026, 15:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pgsync 0.6.7. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems pgsync: affected < 0.6.7; fixed in 0.6.7 ## Suggested inspection (read-only) - RubyGems pgsync: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pgsync. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-72rj-36qc-47g7 (GitHub-reviewed advisory GHSA-72rj-36qc-47g7 lists affected ranges: RubyGems pgsync >=0 <0.6.7) Commands are suggestions: review each one before running it.
Loading voting…