Skip to content

← Actionable
Critical, CVSS 9.4amended

Improper Certificate Validation in xmlhttprequest-ssl

CVE-2021-31597GHSA-72mh-269x-7mh5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (xmlhttprequest-ssl 1.6.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L
EPSS
  • CVE-2021-31597: 2.04% estimated exploitation activity in the next 30 days; percentile 81.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The xmlhttprequest-ssl package before 1.6.1 for Node.js disables SSL certificate validation by default, because rejectUnauthorized (when the property exists but is undefined) is considered to be false within the https.request function of Node.js. In other words, no certificate is ever rejected.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-72mh-269x-7mh5

  2. Revision 1 · created ·

    Published from osv record GHSA-72mh-269x-7mh5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-31597

Advisory: Improper Certificate Validation in xmlhttprequest-ssl
IDs: CVE-2021-31597, GHSA-72mh-269x-7mh5
Record: https://patchnext.com/advisories/cve-2021-31597 (revision 2, source checked 26 Oct 2026, 12:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: xmlhttprequest-ssl 1.6.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm xmlhttprequest-ssl: affected < 1.6.1; fixed in 1.6.1

## Suggested inspection (read-only)
- `npm ls xmlhttprequest-ssl --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on xmlhttprequest-ssl.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-72mh-269x-7mh5 (OSV record GHSA-72mh-269x-7mh5 lists affected ranges: npm xmlhttprequest-ssl >=0 <1.6.1 (fixed))
- Verified: https://github.com/advisories/GHSA-72mh-269x-7mh5 (GitHub-reviewed advisory GHSA-72mh-269x-7mh5 lists affected ranges: npm xmlhttprequest-ssl >=0 <1.6.1)

Commands are suggestions: review each one before running it.

Loading voting…