Skip to content

← Actionable
Unrated

XSS in Mautic

CVE-2021-3142GHSA-p7v4-gm6j-cw9m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mautic/core 3.2.4, 2.16.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist mautic/core

    Affected
    >= 3.0.0, < 3.2.4>= 2.0.0, < 2.16.5
    Fixed in
    3.2.4, 2.16.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact This is a cross-site scripting vulnerability relating to creating/editing a company which requires the user to be logged in as an administrator to be executed. This vulnerability was reported by Dardan Prebreza at Bishop Fox. Patches Upgrade to 3.2.4 or 2.16.5. Link to patch for 2.x versions: https://github.com/mautic/mautic/compare/2.16.4...2.16.5.diff Link to patch for 3.x versions: https://github.com/mautic/mautic/compare/3.2.2...3.2.4.diff Workarounds None References https://www.mautic.org/blog/community/security-release-all-versions-mautic-prior-2-16-5-and-3-2-4 For more information If you have any questions or comments about this advisory: Post in https://forum.mautic.org/c/support Email us at security@mautic.org

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-p7v4-gm6j-cw9m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-3142

Advisory: XSS in Mautic
IDs: CVE-2021-3142, GHSA-p7v4-gm6j-cw9m
Record: https://patchnext.com/advisories/cve-2021-3142 (revision 1, source checked 26 Oct 2026, 14:15 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mautic/core 3.2.4, 2.16.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist mautic/core: affected >= 3.0.0, < 3.2.4; >= 2.0.0, < 2.16.5; fixed in 3.2.4, 2.16.5

## Suggested inspection (read-only)
- Packagist mautic/core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mautic/core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-p7v4-gm6j-cw9m (GitHub-reviewed advisory GHSA-p7v4-gm6j-cw9m lists affected ranges: Packagist mautic/core >=3.0.0 =2.0.0 <2.16.5)

Commands are suggestions: review each one before running it.

Loading voting…