OSGi applications using Vaadin 12-14 and 19 vulnerable to server classes and resources exposure
CVE-2021-31407GHSA-25xc-jwfq-39jw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.vaadin:flow-server 6.0.1, 2.4.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.vaadin:flow-server
- Affected
- >= 6.0.0, <= 6.0.0>= 1.2.0, <= 2.4.7
- Fixed in
- 2.4.8, 6.0.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-25xc-jwfq-39jw lists affected ranges: Maven com.vaadin:flow-server >=6.0.0 =1.2.0 <=2.4.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
- EPSS
- CVE-2021-31407: 2.38% estimated exploitation activity in the next 30 days; percentile 83.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Vulnerability in OSGi integration in com.vaadin:flow-server versions 1.2.0 through 2.4.7 (Vaadin 12.0.0 through 14.4.9), and 6.0.0 through 6.0.1 (Vaadin 19.0.0) allows attacker to access application classes and resources on the server via crafted HTTP request. - https://vaadin.com/security/cve-2021-31407
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-25xc-jwfq-39jw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-31407 Advisory: OSGi applications using Vaadin 12-14 and 19 vulnerable to server classes and resources exposure IDs: CVE-2021-31407, GHSA-25xc-jwfq-39jw Record: https://patchnext.com/advisories/cve-2021-31407 (revision 1, source checked 26 Oct 2026, 15:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.vaadin:flow-server 6.0.1, 2.4.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.vaadin:flow-server: affected >= 6.0.0, <= 6.0.0; >= 1.2.0, <= 2.4.7; fixed in 2.4.8, 6.0.1 ## Suggested inspection (read-only) - Maven com.vaadin:flow-server: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.vaadin:flow-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-25xc-jwfq-39jw (GitHub-reviewed advisory GHSA-25xc-jwfq-39jw lists affected ranges: Maven com.vaadin:flow-server >=6.0.0 =1.2.0 <=2.4.7) Commands are suggestions: review each one before running it.
Loading voting…