Skip to content

← Actionable
Medium, CVSS 6.5

Authentication Bypass by Alternate Name in Apache Tomcat

CVE-2021-30640GHSA-36qh-35cm-5w2w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.tomcat:tomcat 10.0.5, 9.0.45, 8.5.65), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven org.apache.tomcat:tomcat

    Affected
    >= 10.0.0-M1, < 10.0.5>= 9.0.0M1, < 9.0.45>= 8.5.0, < 8.5.65
    Fixed in
    10.0.5, 9.0.45, 8.5.65

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:H/A:N
EPSS
  • CVE-2021-30640: 9.89% estimated exploitation activity in the next 30 days; percentile 95.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A vulnerability in the JNDI Realm of Apache Tomcat allows an attacker to authenticate using variations of a valid user name and/or to bypass some of the protection provided by the LockOut Realm. This issue affects Apache Tomcat 10.0.0-M1 to 10.0.5; 9.0.0.M1 to 9.0.45; 8.5.0 to 8.5.65.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-36qh-35cm-5w2w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-30640

Advisory: Authentication Bypass by Alternate Name in Apache Tomcat
IDs: CVE-2021-30640, GHSA-36qh-35cm-5w2w
Record: https://patchnext.com/advisories/cve-2021-30640 (revision 1, source checked 26 Oct 2026, 16:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.tomcat:tomcat 10.0.5, 9.0.45, 8.5.65. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.tomcat:tomcat: affected >= 10.0.0-M1, < 10.0.5; >= 9.0.0M1, < 9.0.45; >= 8.5.0, < 8.5.65; fixed in 10.0.5, 9.0.45, 8.5.65

## Suggested inspection (read-only)
- Maven org.apache.tomcat:tomcat: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.tomcat:tomcat.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-36qh-35cm-5w2w (GitHub-reviewed advisory GHSA-36qh-35cm-5w2w lists affected ranges: Maven org.apache.tomcat:tomcat >=10.0.0-M1 =9.0.0M1 =8.5.0 <8.5.65)

Commands are suggestions: review each one before running it.

Loading voting…