Skip to content

← Actionable
Critical, CVSS 9.8

Uninitialized memory access in outer_cgi

CVE-2021-30454GHSA-6vmq-jh76-hq43

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (outer_cgi 0.2.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io outer_cgi

    Affected
    < 0.2.1
    Fixed in
    0.2.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2021-30454: 1.14% estimated exploitation activity in the next 30 days; percentile 66.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

An issue was discovered in the outercgi crate before 0.2.1 for Rust. A user-provided Read instance receives an uninitialized memory buffer from KeyValueReader.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-6vmq-jh76-hq43

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-30454

Advisory: Uninitialized memory access in outer_cgi
IDs: CVE-2021-30454, GHSA-6vmq-jh76-hq43
Record: https://patchnext.com/advisories/cve-2021-30454 (revision 1, source checked 26 Oct 2026, 15:33 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: outer_cgi 0.2.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io outer_cgi: affected < 0.2.1; fixed in 0.2.1

## Suggested inspection (read-only)
- crates.io outer_cgi: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on outer_cgi.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6vmq-jh76-hq43 (GitHub-reviewed advisory GHSA-6vmq-jh76-hq43 lists affected ranges: crates.io outer_cgi >=0 <0.2.1)

Commands are suggestions: review each one before running it.

Loading voting…