RSA signature validation vulnerability on maleable encoded message in jsrsasign
CVE-2021-30246GHSA-27fj-mc8w-j9wg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (jsrsasign 10.2.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm jsrsasign
- Affected
- < 10.2.0
- Fixed in
- 10.2.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-27fj-mc8w-j9wg lists affected ranges: npm jsrsasign >=0 <10.2.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-27fj-mc8w-j9wg lists affected ranges: npm jsrsasign >=0 <10.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2021-30246: 0.96% estimated exploitation activity in the next 30 days; percentile 61.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Vulnerable jsrsasign will accept RSA signature with improper PKCS#1.5 padding. Decoded RSA signature value consists following form: 01(ff...(8 or more ffs)...ff)00[ASN.1 OF DigestInfo] Its byte length must be the same as RSA key length, however such checking was not sufficient. To make crafted message for practical attack is very hard. Patches Users validating RSA signature should upgrade to 10.2.0 or later. Workarounds There is no workaround. Not to use RSA signature validation in jsrsasign. ACKNOWLEDGEMENT Thanks to Daniel Yahyazadeh @yahyazadeh for reporting and analyzing this vulnerability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-27fj-mc8w-j9wg
- Revision 1 · created ·
Published from osv record GHSA-27fj-mc8w-j9wg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-30246 Advisory: RSA signature validation vulnerability on maleable encoded message in jsrsasign IDs: CVE-2021-30246, GHSA-27fj-mc8w-j9wg Record: https://patchnext.com/advisories/cve-2021-30246 (revision 2, source checked 26 Oct 2026, 12:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: jsrsasign 10.2.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm jsrsasign: affected < 10.2.0; fixed in 10.2.0 ## Suggested inspection (read-only) - `npm ls jsrsasign --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on jsrsasign. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-27fj-mc8w-j9wg (OSV record GHSA-27fj-mc8w-j9wg lists affected ranges: npm jsrsasign >=0 <10.2.0 (fixed)) - Verified: https://github.com/advisories/GHSA-27fj-mc8w-j9wg (GitHub-reviewed advisory GHSA-27fj-mc8w-j9wg lists affected ranges: npm jsrsasign >=0 <10.2.0) Commands are suggestions: review each one before running it.
Loading voting…