Code injection in Apache Dubbo
CVE-2021-30181GHSA-qmfc-6www-fjqw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.dubbo:dubbo 2.7.10; com.alibaba:dubbo 2.6.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.dubbo:dubbo
- Affected
- >= 2.5.0, < 2.7.10
- Fixed in
- 2.7.10
Maven com.alibaba:dubbo
- Affected
- >= 2.5.0, < 2.6.9
- Fixed in
- 2.6.9
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qmfc-6www-fjqw lists affected ranges: Maven com.alibaba:dubbo >=2.5.0 =2.5.0 <2.7.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2021-30181: 60.86% estimated exploitation activity in the next 30 days; percentile 99.15 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Apache Dubbo prior to 2.6.9 and 2.7.10 supports Script routing which will enable a customer to route the request to the right server. These rules are used by the customers when making a request in order to find the right endpoint. When parsing these rules, Dubbo customers use ScriptEngine and run the rule provided by the script which by default may enable executing arbitrary code.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-qmfc-6www-fjqw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-30181 Advisory: Code injection in Apache Dubbo IDs: CVE-2021-30181, GHSA-qmfc-6www-fjqw Record: https://patchnext.com/advisories/cve-2021-30181 (revision 1, source checked 26 Oct 2026, 16:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.dubbo:dubbo 2.7.10; com.alibaba:dubbo 2.6.9. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.dubbo:dubbo: affected >= 2.5.0, < 2.7.10; fixed in 2.7.10 - Maven com.alibaba:dubbo: affected >= 2.5.0, < 2.6.9; fixed in 2.6.9 ## Suggested inspection (read-only) - Maven org.apache.dubbo:dubbo: check the installed version with your package manager. - Maven com.alibaba:dubbo: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.dubbo:dubbo, com.alibaba:dubbo. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-qmfc-6www-fjqw (GitHub-reviewed advisory GHSA-qmfc-6www-fjqw lists affected ranges: Maven com.alibaba:dubbo >=2.5.0 =2.5.0 <2.7.10) Commands are suggestions: review each one before running it.
Loading voting…