Improper Certificate Validation in phpseclib
CVE-2021-30130GHSA-vf4w-fg7r-5v94
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpseclib/phpseclib 3.0.7, 2.0.31), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist phpseclib/phpseclib
- Affected
- >= 3.0.0, < 3.0.7< 2.0.31
- Fixed in
- 2.0.31, 3.0.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vf4w-fg7r-5v94 lists affected ranges: Packagist phpseclib/phpseclib >=3.0.0 =0 <2.0.31
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2021-30130: 1.05% estimated exploitation activity in the next 30 days; percentile 64.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
phpseclib before 2.0.31 and 3.x before 3.0.7 mishandles RSA PKCS#1 v1.5 signature verification.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vf4w-fg7r-5v94
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-30130 Advisory: Improper Certificate Validation in phpseclib IDs: CVE-2021-30130, GHSA-vf4w-fg7r-5v94 Record: https://patchnext.com/advisories/cve-2021-30130 (revision 1, source checked 26 Oct 2026, 14:15 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: phpseclib/phpseclib 3.0.7, 2.0.31. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist phpseclib/phpseclib: affected >= 3.0.0, < 3.0.7; < 2.0.31; fixed in 2.0.31, 3.0.7 ## Suggested inspection (read-only) - Packagist phpseclib/phpseclib: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on phpseclib/phpseclib. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vf4w-fg7r-5v94 (GitHub-reviewed advisory GHSA-vf4w-fg7r-5v94 lists affected ranges: Packagist phpseclib/phpseclib >=3.0.0 =0 <2.0.31) Commands are suggestions: review each one before running it.
Loading voting…