OS command injection in ripgrep
CVE-2021-3013GHSA-g4xg-fxmg-vcg5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ripgrep 13.0.0; grep-cli 0.1.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g4xg-fxmg-vcg5 lists affected ranges: crates.io ripgrep >=0 =0 <0.1.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2021-3013: 1.93% estimated exploitation activity in the next 30 days; percentile 80.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
ripgrep before 13 on Windows allows attackers to trigger execution of arbitrary programs from the current working directory via the -z/--search-zip or --pre flag.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-g4xg-fxmg-vcg5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-3013 Advisory: OS command injection in ripgrep IDs: CVE-2021-3013, GHSA-g4xg-fxmg-vcg5 Record: https://patchnext.com/advisories/cve-2021-3013 (revision 1, source checked 26 Oct 2026, 15:33 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ripgrep 13.0.0; grep-cli 0.1.6. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io ripgrep: affected < 13.0.0; fixed in 13.0.0 - crates.io grep-cli: affected < 0.1.6; fixed in 0.1.6 ## Suggested inspection (read-only) - crates.io ripgrep: check the installed version with your package manager. - crates.io grep-cli: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ripgrep, grep-cli. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-g4xg-fxmg-vcg5 (GitHub-reviewed advisory GHSA-g4xg-fxmg-vcg5 lists affected ranges: crates.io ripgrep >=0 =0 <0.1.6) Commands are suggestions: review each one before running it.
Loading voting…