Remote code execution in zendframework and laminas-http
CVE-2021-3007GHSA-xx8f-qf9f-5fgw
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist zendframework/zendframework
- Affected
- <= 3.0.0
- Fixed in
- no fixed version recorded
Packagist laminas/laminas-http
- Affected
- < 2.14.2
- Fixed in
- 2.14.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xx8f-qf9f-5fgw lists affected ranges: Packagist zendframework/zendframework >=0 =0 <2.14.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2021-3007: 75.31% estimated exploitation activity in the next 30 days; percentile 99.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Laminas Project laminas-http before 2.14.2, and Zend Framework 3.0.0, has a deserialization vulnerability that can lead to remote code execution if the content is controllable, related to the destruct method of the Zend\Http\Response\Stream class in Stream.php. NOTE: Zend Framework is no longer supported by the maintainer. NOTE: the laminas-http vendor considers this a "vulnerability in the PHP language itself" but has added certain type checking as a way to prevent exploitation in (unrecommended) use cases where attacker-supplied data can be deserialized.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-xx8f-qf9f-5fgw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-3007 Advisory: Remote code execution in zendframework and laminas-http IDs: CVE-2021-3007, GHSA-xx8f-qf9f-5fgw Record: https://patchnext.com/advisories/cve-2021-3007 (revision 1, source checked 26 Oct 2026, 14:19 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: laminas/laminas-http 2.14.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist zendframework/zendframework: affected <= 3.0.0 - Packagist laminas/laminas-http: affected < 2.14.2; fixed in 2.14.2 ## Suggested inspection (read-only) - Packagist zendframework/zendframework: check the installed version with your package manager. - Packagist laminas/laminas-http: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on zendframework/zendframework, laminas/laminas-http. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-xx8f-qf9f-5fgw (GitHub-reviewed advisory GHSA-xx8f-qf9f-5fgw lists affected ranges: Packagist zendframework/zendframework >=0 =0 <2.14.2) Commands are suggestions: review each one before running it.
Loading voting…