Incorrect Authorization in Apache Solr
CVE-2021-29943GHSA-vf7p-j8x6-xvwp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.solr:solr-parent 8.8.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.solr:solr-parent
- Affected
- < 8.8.2
- Fixed in
- 8.8.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vf7p-j8x6-xvwp lists affected ranges: Maven org.apache.solr:solr-parent >=0 <8.8.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2021-29943: 4.67% estimated exploitation activity in the next 30 days; percentile 91.77 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
When using ConfigurableInternodeAuthHadoopPlugin for authentication, Apache Solr versions prior to 8.8.2 would forward/proxy distributed requests using server credentials instead of original client credentials. This would result in incorrect authorization resolution on the receiving hosts.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vf7p-j8x6-xvwp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-29943 Advisory: Incorrect Authorization in Apache Solr IDs: CVE-2021-29943, GHSA-vf7p-j8x6-xvwp Record: https://patchnext.com/advisories/cve-2021-29943 (revision 1, source checked 26 Oct 2026, 16:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.solr:solr-parent 8.8.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.solr:solr-parent: affected < 8.8.2; fixed in 8.8.2 ## Suggested inspection (read-only) - Maven org.apache.solr:solr-parent: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.solr:solr-parent. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vf7p-j8x6-xvwp (GitHub-reviewed advisory GHSA-vf7p-j8x6-xvwp lists affected ranges: Maven org.apache.solr:solr-parent >=0 <8.8.2) Commands are suggestions: review each one before running it.
Loading voting…