Skip to content

← Actionable
Medium, CVSS 6.1

pomerium_signature is not verified in middleware in github.com/pomerium/pomerium

CVE-2021-29652GHSA-fv82-r8qv-ch4v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/pomerium/pomerium 0.13.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2021-29652: 0.66% estimated exploitation activity in the next 30 days; percentile 51.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Some API endpoints under /.pomerium/ do not verify parameters with pomeriumsignature. This could allow modifying parameters intended to be trusted to Pomerium. The issue mainly affects routes responsible for sign in/out, but does not introduce an authentication bypass. Specific Go Packages Affected github.com/pomerium/pomerium/authenticate Patches Patched in v0.13.4 For more information If you have any questions or comments about this advisory Open an issue in pomerium Email us at security@pomerium.com

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-fv82-r8qv-ch4v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-29652

Advisory: pomerium_signature is not verified in middleware in github.com/pomerium/pomerium
IDs: CVE-2021-29652, GHSA-fv82-r8qv-ch4v
Record: https://patchnext.com/advisories/cve-2021-29652 (revision 1, source checked 26 Oct 2026, 14:59 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/pomerium/pomerium 0.13.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/pomerium/pomerium: affected >= 0.10.0, < 0.13.4; fixed in 0.13.4

## Suggested inspection (read-only)
- Go github.com/pomerium/pomerium: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/pomerium/pomerium.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-fv82-r8qv-ch4v (GitHub-reviewed advisory GHSA-fv82-r8qv-ch4v lists affected ranges: Go github.com/pomerium/pomerium >=0.10.0 <0.13.4)

Commands are suggestions: review each one before running it.

Loading voting…