Skip to content

← Actionable
Medium, CVSS 6.5amended

Lack of protection against cookie tossing attacks in fastify-csrf

CVE-2021-29624GHSA-rc4q-9m69-gqp8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (fastify-csrf 3.1.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
EPSS
  • CVE-2021-29624: 0.83% estimated exploitation activity in the next 30 days; percentile 57.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Users that used fastify-csrf with the "double submit" mechanism using cookies with an application deployed across multiple subdomains, e.g. "heroku"-style platform as a service. Patches Version 3.1.0 of the fastify-csrf fixes it. See https://github.com/fastify/fastify-csrf/pull/51 and https://github.com/fastify/csrf/pull/2. The user of the module would need to supply a userInfo when generating the CSRF token to fully implement the protection on their end. This is needed only for applications hosted on different subdomains. Workarounds None available. References 1. https://cheatsheetseries.owasp.org/cheatsheets/Cross-SiteRequestForgeryPreventionCheatSheet.html 2. https://owasp.org/www-pdf-archive/DavidJohansson-DoubleDefeatofDouble-SubmitCookie.pdf Credits This vulnerability was found by Xhelal Likaj <xhelallikaj20@gmail.com. For more information If you have any questions or comments about this advisory: Open an issue in fastify-csrf Email us at hello@matteocollina.com

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-rc4q-9m69-gqp8

  2. Revision 1 · created ·

    Published from osv record GHSA-rc4q-9m69-gqp8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-29624

Advisory: Lack of protection against cookie tossing attacks in fastify-csrf
IDs: CVE-2021-29624, GHSA-rc4q-9m69-gqp8
Record: https://patchnext.com/advisories/cve-2021-29624 (revision 2, source checked 26 Oct 2026, 12:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: fastify-csrf 3.1.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm fastify-csrf: affected < 3.1.0; fixed in 3.1.0

## Suggested inspection (read-only)
- `npm ls fastify-csrf --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fastify-csrf.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-rc4q-9m69-gqp8 (OSV record GHSA-rc4q-9m69-gqp8 lists affected ranges: npm fastify-csrf >=0 <3.1.0 (fixed))
- Verified: https://github.com/advisories/GHSA-rc4q-9m69-gqp8 (GitHub-reviewed advisory GHSA-rc4q-9m69-gqp8 lists affected ranges: npm fastify-csrf >=0 <3.1.0)

Commands are suggestions: review each one before running it.

Loading voting…