Skip to content

← Actionable
Low, CVSS 2.0amended

Heap buffer overflow in BandedTriangularSolve

CVE-2021-29612GHSA-2xgj-xhgf-ggjv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tensorflow 2.4.2, 2.3.3, 2.2.3, 2.1.4; tensorflow-gpu 2.4.2, 2.3.3, 2.2.3, 2.1.4; tensorflow-cpu 2.4.2, 2.3.3, 2.2.3, 2.1.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI tensorflow

    Affected
    < 2.1.4>= 2.2.0, < 2.2.3>= 2.3.0, < 2.3.3>= 2.4.0, < 2.4.2
    Fixed in
    2.4.2, 2.3.3, 2.2.3, 2.1.4
  • PyPI tensorflow-gpu

    Affected
    < 2.1.4>= 2.2.0, < 2.2.3>= 2.3.0, < 2.3.3>= 2.4.0, < 2.4.2
    Fixed in
    2.4.2, 2.3.3, 2.2.3, 2.1.4
  • PyPI tensorflow-cpu

    Affected
    < 2.1.4>= 2.2.0, < 2.2.3>= 2.3.0, < 2.3.3>= 2.4.0, < 2.4.2
    Fixed in
    2.4.2, 2.3.3, 2.2.3, 2.1.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.0 · CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2021-29612: 0.29% estimated exploitation activity in the next 30 days; percentile 21.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An attacker can trigger a heap buffer overflow in Eigen implementation of tf.rawops.BandedTriangularSolve: The implementation calls ValidateInputTensors for input validation but fails to validate that the two tensors are not empty: Furthermore, since OPREQUIRES macro only stops execution of current function after setting ctx-status() to a non-OK value, callers of helper functions that use OPREQUIRES must check value of ctx-status() before continuing. This doesn't happen in this op's implementation, hence the validation that is present is also not effective. Patches We have patched the issue in GitHub commit ba6822bd7b7324ba201a28b2f278c29a98edbef2 followed by GitHub commit 0ab290774f91a23bebe30a358fde4e53ab4876a0. The fix will be included in TensorFlow 2.5.0. We will also cherrypick this commit on TensorFlow 2.4.2, TensorFlow 2.3.3, TensorFlow 2.2.3 and TensorFlow 2.1.4, as these are also affected and still in supported range. For more information Please consult our security…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-2xgj-xhgf-ggjv

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-2xgj-xhgf-ggjv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-29612

Advisory: Heap buffer overflow in `BandedTriangularSolve`
IDs: CVE-2021-29612, GHSA-2xgj-xhgf-ggjv
Record: https://patchnext.com/advisories/cve-2021-29612 (revision 3, source checked 26 Oct 2026, 13:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tensorflow 2.4.2, 2.3.3, 2.2.3, 2.1.4; tensorflow-gpu 2.4.2, 2.3.3, 2.2.3, 2.1.4; tensorflow-cpu 2.4.2, 2.3.3, 2.2.3, 2.1.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI tensorflow: affected < 2.1.4; >= 2.2.0, < 2.2.3; >= 2.3.0, < 2.3.3; >= 2.4.0, < 2.4.2; fixed in 2.4.2, 2.3.3, 2.2.3, 2.1.4
- PyPI tensorflow-gpu: affected < 2.1.4; >= 2.2.0, < 2.2.3; >= 2.3.0, < 2.3.3; >= 2.4.0, < 2.4.2; fixed in 2.4.2, 2.3.3, 2.2.3, 2.1.4
- PyPI tensorflow-cpu: affected < 2.1.4; >= 2.2.0, < 2.2.3; >= 2.3.0, < 2.3.3; >= 2.4.0, < 2.4.2; fixed in 2.4.2, 2.3.3, 2.2.3, 2.1.4

## Suggested inspection (read-only)
- `python -m pip show tensorflow`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show tensorflow-gpu`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show tensorflow-cpu`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tensorflow, tensorflow-gpu, tensorflow-cpu.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2xgj-xhgf-ggjv (OSV record GHSA-2xgj-xhgf-ggjv lists affected ranges: PyPI tensorflow >=0 =2.2.0 =2.3.0 =2.4.0 =0 =2.2.0 =2.3.0 =2.4.0 =0 =2.2.0 =2.3.0 =2.4.0 <2.4.2 (fixed))
- Verified: https://github.com/advisories/GHSA-2xgj-xhgf-ggjv (GitHub-reviewed advisory GHSA-2xgj-xhgf-ggjv lists affected ranges: PyPI tensorflow >=0 =2.2.0 =2.3.0 =2.4.0 =0 =2.2.0 =2.3.0 =2.4.0 =0 =2.2.0 =2.3.0 =2.4.0 <2.4.2)

Commands are suggestions: review each one before running it.

Loading voting…