Heap OOB write in TFLite
CVE-2021-29603GHSA-crch-j389-5f84
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (tensorflow 2.4.2, 2.3.3, 2.2.3, 2.1.4; tensorflow-gpu 2.4.2, 2.3.3, 2.2.3, 2.1.4; tensorflow-cpu 2.4.2, 2.3.3, 2.2.3, 2.1.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI tensorflow
- Affected
- < 2.1.4>= 2.2.0, < 2.2.3>= 2.3.0, < 2.3.3>= 2.4.0, < 2.4.2
- Fixed in
- 2.4.2, 2.3.3, 2.2.3, 2.1.4
PyPI tensorflow-gpu
- Affected
- < 2.1.4>= 2.2.0, < 2.2.3>= 2.3.0, < 2.3.3>= 2.4.0, < 2.4.2
- Fixed in
- 2.4.2, 2.3.3, 2.2.3, 2.1.4
PyPI tensorflow-cpu
- Affected
- < 2.1.4>= 2.2.0, < 2.2.3>= 2.3.0, < 2.3.3>= 2.4.0, < 2.4.2
- Fixed in
- 2.4.2, 2.3.3, 2.2.3, 2.1.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-crch-j389-5f84 lists affected ranges: PyPI tensorflow >=0 =2.2.0 =2.3.0 =2.4.0 =0 =2.2.0 =2.3.0 =2.4.0 =0 =2.2.0 =2.3.0 =2.4.0 <2.4.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-crch-j389-5f84 lists affected ranges: PyPI tensorflow >=0 =2.2.0 =2.3.0 =2.4.0 =0 =2.2.0 =2.3.0 =2.4.0 =0 =2.2.0 =2.3.0 =2.4.0 <2.4.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.0 · CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2021-29603: 0.20% estimated exploitation activity in the next 30 days; percentile 10.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A specially crafted TFLite model could trigger an OOB write on heap in the TFLite implementation of ArgMin/ArgMax: If axisvalue is not a value between 0 and NumDimensions(input), then the condition in the if is never true, so code writes past the last valid element of outputdims-data. Patches We have patched the issue in GitHub commit c59c37e7b2d563967da813fa50fe20b21f4da683. The fix will be included in TensorFlow 2.5.0. We will also cherrypick this commit on TensorFlow 2.4.2, TensorFlow 2.3.3, TensorFlow 2.2.3 and TensorFlow 2.1.4, as these are also affected and still in supported range. For more information Please consult our security guide for more information regarding the security model and how to contact us with issues and questions. Attribution This vulnerability has been reported by members of the Aivul Team from Qihoo 360.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-crch-j389-5f84
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-crch-j389-5f84
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-29603 Advisory: Heap OOB write in TFLite IDs: CVE-2021-29603, GHSA-crch-j389-5f84 Record: https://patchnext.com/advisories/cve-2021-29603 (revision 3, source checked 26 Oct 2026, 13:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: tensorflow 2.4.2, 2.3.3, 2.2.3, 2.1.4; tensorflow-gpu 2.4.2, 2.3.3, 2.2.3, 2.1.4; tensorflow-cpu 2.4.2, 2.3.3, 2.2.3, 2.1.4. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI tensorflow: affected < 2.1.4; >= 2.2.0, < 2.2.3; >= 2.3.0, < 2.3.3; >= 2.4.0, < 2.4.2; fixed in 2.4.2, 2.3.3, 2.2.3, 2.1.4 - PyPI tensorflow-gpu: affected < 2.1.4; >= 2.2.0, < 2.2.3; >= 2.3.0, < 2.3.3; >= 2.4.0, < 2.4.2; fixed in 2.4.2, 2.3.3, 2.2.3, 2.1.4 - PyPI tensorflow-cpu: affected < 2.1.4; >= 2.2.0, < 2.2.3; >= 2.3.0, < 2.3.3; >= 2.4.0, < 2.4.2; fixed in 2.4.2, 2.3.3, 2.2.3, 2.1.4 ## Suggested inspection (read-only) - `python -m pip show tensorflow`: prints the installed version. Run with the environment that serves production active. - `python -m pip show tensorflow-gpu`: prints the installed version. Run with the environment that serves production active. - `python -m pip show tensorflow-cpu`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on tensorflow, tensorflow-gpu, tensorflow-cpu. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-crch-j389-5f84 (OSV record GHSA-crch-j389-5f84 lists affected ranges: PyPI tensorflow >=0 =2.2.0 =2.3.0 =2.4.0 =0 =2.2.0 =2.3.0 =2.4.0 =0 =2.2.0 =2.3.0 =2.4.0 <2.4.2 (fixed)) - Verified: https://github.com/advisories/GHSA-crch-j389-5f84 (GitHub-reviewed advisory GHSA-crch-j389-5f84 lists affected ranges: PyPI tensorflow >=0 =2.2.0 =2.3.0 =2.4.0 =0 =2.2.0 =2.3.0 =2.4.0 =0 =2.2.0 =2.3.0 =2.4.0 <2.4.2) Commands are suggestions: review each one before running it.
Loading voting…