Skip to content

← Actionable
Medium, CVSS 6.5

Memory over-allocation in evm crate

CVE-2021-29511GHSA-4jwq-572w-4388

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (evm-core 0.26.1, 0.25.1, 0.24.1, 0.23.1, 0.22.1, 0.21.1; evm 0.26.1, 0.25.1, 0.24.1, 0.23.1, 0.22.1, 0.21.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io evm-core

    Affected
    <= 0.21.0>= 0.22.0, <= 0.22.0>= 0.23.0, <= 0.23.0>= 0.24.0, <= 0.24.0>= 0.25.0, <= 0.25.0>= 0.26.0, <= 0.26.0
    Fixed in
    0.25.1, 0.22.1, 0.24.1, 0.23.1, 0.26.1, 0.21.1
  • crates.io evm

    Affected
    <= 0.21.0>= 0.22.0, <= 0.22.0>= 0.23.0, <= 0.23.0>= 0.24.0, <= 0.24.0>= 0.25.0, <= 0.25.0>= 0.26.0, <= 0.26.0
    Fixed in
    0.25.1, 0.22.1, 0.24.1, 0.23.1, 0.26.1, 0.21.1

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-4jwq-572w-4388 lists affected ranges: crates.io evm >=0 =0.22.0 =0.23.0 =0.24.0 =0.25.0 =0.26.0 =0 =0.22.0 =0.23.0 =0.24.0 =0.25.0 =0.26.0 <=0.26.0

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2021-29511: 1.28% estimated exploitation activity in the next 30 days; percentile 70.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Prior to the patch, when executing specific EVM opcodes related to memory operations that use evmcore::Memory::copylarge, the crate can over-allocate memory when it is not needed, making it possible for an attacker to perform denial-of-service attack. Patches The flaw was corrected in commit 19ade85. Users should upgrade to ==0.21.1, ==0.23.1, ==0.24.1, ==0.25.1, =0.26.1. Workarounds None. Please upgrade your evm crate version References Fix commit: https://github.com/rust-blockchain/evm/commit/19ade858c430ab13eb562764a870ac9f8506f8dd For more information If you have any questions or comments about this advisory: Open an issue in evm repo Email Wei

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4jwq-572w-4388

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-29511

Advisory: Memory over-allocation in evm crate
IDs: CVE-2021-29511, GHSA-4jwq-572w-4388
Record: https://patchnext.com/advisories/cve-2021-29511 (revision 1, source checked 26 Oct 2026, 15:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: evm-core 0.26.1, 0.25.1, 0.24.1, 0.23.1, 0.22.1, 0.21.1; evm 0.26.1, 0.25.1, 0.24.1, 0.23.1, 0.22.1, 0.21.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io evm-core: affected <= 0.21.0; >= 0.22.0, <= 0.22.0; >= 0.23.0, <= 0.23.0; >= 0.24.0, <= 0.24.0; >= 0.25.0, <= 0.25.0; >= 0.26.0, <= 0.26.0; fixed in 0.25.1, 0.22.1, 0.24.1, 0.23.1, 0.26.1, 0.21.1
- crates.io evm: affected <= 0.21.0; >= 0.22.0, <= 0.22.0; >= 0.23.0, <= 0.23.0; >= 0.24.0, <= 0.24.0; >= 0.25.0, <= 0.25.0; >= 0.26.0, <= 0.26.0; fixed in 0.25.1, 0.22.1, 0.24.1, 0.23.1, 0.26.1, 0.21.1

## Suggested inspection (read-only)
- crates.io evm-core: check the installed version with your package manager.
- crates.io evm: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on evm-core, evm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4jwq-572w-4388 (GitHub-reviewed advisory GHSA-4jwq-572w-4388 lists affected ranges: crates.io evm >=0 =0.22.0 =0.23.0 =0.24.0 =0.25.0 =0.26.0 =0 =0.22.0 =0.23.0 =0.24.0 =0.25.0 =0.26.0 <=0.26.0)

Commands are suggestions: review each one before running it.

Loading voting…