Skip to content

← Actionable
High, CVSS 7.5

Puma's Keepalive Connections Causing Denial Of Service

CVE-2021-29509GHSA-q28m-8xjw-8vr5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (puma 5.3.1, 4.3.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems puma

    Affected
    <= 4.3.7>= 5.0.0, <= 5.3.0
    Fixed in
    5.3.1, 4.3.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2021-29509: 1.60% estimated exploitation activity in the next 30 days; percentile 75.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

This vulnerability is related to CVE-2019-16770. Impact The fix for CVE-2019-16770 was incomplete. The original fix only protected existing connections that had already been accepted from having their requests starved by greedy persistent-connections saturating all threads in the same process. However, new connections may still be starved by greedy persistent-connections saturating all threads in all processes in the cluster. A puma server which received more concurrent keep-alive connections than the server had threads in its threadpool would service only a subset of connections, denying service to the unserved connections. Patches This problem has been fixed in puma 4.3.8 and 5.3.1. Workarounds Setting queuerequests false also fixes the issue. This is not advised when using puma without a reverse proxy, such as nginx or apache, because you will open yourself to slow client attacks (e.g. slowloris)). The fix is very small. A git patch is available here for those using unsupported…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-q28m-8xjw-8vr5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-29509

Advisory: Puma's Keepalive Connections Causing Denial Of Service
IDs: CVE-2021-29509, GHSA-q28m-8xjw-8vr5
Record: https://patchnext.com/advisories/cve-2021-29509 (revision 1, source checked 26 Oct 2026, 15:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: puma 5.3.1, 4.3.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems puma: affected <= 4.3.7; >= 5.0.0, <= 5.3.0; fixed in 5.3.1, 4.3.8

## Suggested inspection (read-only)
- RubyGems puma: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on puma.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-q28m-8xjw-8vr5 (GitHub-reviewed advisory GHSA-q28m-8xjw-8vr5 lists affected ranges: RubyGems puma >=0 =5.0.0 <=5.3.0)

Commands are suggestions: review each one before running it.

Loading voting…