Improper Certificate Validation in WP-CLI framework
CVE-2021-29504GHSA-rwgm-f83r-v3qj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (wp-cli/wp-cli 2.5.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist wp-cli/wp-cli
- Affected
- >= 0.12.0, < 2.5.0
- Fixed in
- 2.5.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rwgm-f83r-v3qj lists affected ranges: Packagist wp-cli/wp-cli >=0.12.0 <2.5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2021-29504: 1.31% estimated exploitation activity in the next 30 days; percentile 70.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An improper error handling in HTTPS requests management in WP-CLI version 0.12.0 and later allows remote attackers able to intercept the communication to remotely disable the certificate verification on WP-CLI side, gaining full control over the communication content, including the ability to impersonate update servers and push malicious updates towards WordPress instances controlled by the vulnerable WP-CLI agent, or push malicious updates toward WP-CLI itself. Patches The vulnerability stems from the fact that the default behavior of WPCLI\Utils\httprequest() when encountering a TLS handshake error is to disable certificate validation and retry the same request. The default behavior has been changed with version 2.5.0 of WP-CLI and the wp-cli/wp-cli framework (via https://github.com/wp-cli/wp-cli/pull/5523) so that the WPCLI\Utils\httprequest() method accepts an $insecure option that is false by default and consequently that a TLS handshake failure is a hard error by…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-rwgm-f83r-v3qj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-29504 Advisory: Improper Certificate Validation in WP-CLI framework IDs: CVE-2021-29504, GHSA-rwgm-f83r-v3qj Record: https://patchnext.com/advisories/cve-2021-29504 (revision 1, source checked 26 Oct 2026, 14:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: wp-cli/wp-cli 2.5.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist wp-cli/wp-cli: affected >= 0.12.0, < 2.5.0; fixed in 2.5.0 ## Suggested inspection (read-only) - Packagist wp-cli/wp-cli: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on wp-cli/wp-cli. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rwgm-f83r-v3qj (GitHub-reviewed advisory GHSA-rwgm-f83r-v3qj lists affected ranges: Packagist wp-cli/wp-cli >=0.12.0 <2.5.0) Commands are suggestions: review each one before running it.
Loading voting…