Skip to content

← Actionable
High, CVSS 7.6amended

Options structure open to Cross-site Scripting if passed unfiltered

CVE-2021-29489GHSA-8j65-4pcq-xq95

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (highcharts 9.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.6 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:L
EPSS
  • CVE-2021-29489: 0.87% estimated exploitation activity in the next 30 days; percentile 58.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact In Highcharts versions 8 and earlier, the chart options structure was not systematically filtered for XSS vectors. The potential impact was that content from untrusted sources could execute code in the end user's browser. Especially when using the useHTML flag, HTML string options would be inserted unfiltered directly into the DOM. When useHTML was false, malicious code could be inserted by using various character replacement tricks or malformed HTML. If your chart configuration comes from a trusted source like a static setup or pre-filtered HTML (or no markup at all in the configuration), you are not impacted. Patches In version 9, the whole rendering layer was refactored to use an DOMParser, an AST and tag and HTML allow-listing to make sure only safe content entered the DOM. In addition, prototype pollution was stopped. Workarounds Implementers who are not able to upgrade may apply DOMPurify recursively to the options structure to filter out malicious markup. References…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-8j65-4pcq-xq95

  2. Revision 1 · created ·

    Published from osv record GHSA-8j65-4pcq-xq95

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-29489

Advisory: Options structure open to Cross-site Scripting if passed unfiltered
IDs: CVE-2021-29489, GHSA-8j65-4pcq-xq95
Record: https://patchnext.com/advisories/cve-2021-29489 (revision 2, source checked 26 Oct 2026, 12:17 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: highcharts 9.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm highcharts: affected < 9.0.0; fixed in 9.0.0

## Suggested inspection (read-only)
- `npm ls highcharts --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on highcharts.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8j65-4pcq-xq95 (OSV record GHSA-8j65-4pcq-xq95 lists affected ranges: npm highcharts >=0 <9.0.0 (fixed))
- Verified: https://github.com/advisories/GHSA-8j65-4pcq-xq95 (GitHub-reviewed advisory GHSA-8j65-4pcq-xq95 lists affected ranges: npm highcharts >=0 <9.0.0)

Commands are suggestions: review each one before running it.

Loading voting…