Skip to content

← Actionable
Critical, CVSS 9.9

Remote Code Execution Vulnerability in Session Storage

CVE-2021-29485GHSA-hc33-32vw-rpp9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.ratpack:ratpack-core 1.9.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2021-29485: 1.99% estimated exploitation activity in the next 30 days; percentile 80.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A malicious attacker can achieve Remote Code Execution (RCE) via a maliciously crafted Java deserialization gadget chain leveraged against the Ratpack session store. If your application does not use Ratpack's session mechanism, it is not vulnerable. Details Attackers with the ability to write to session data, can potentially craft payloads that deserialize unsafe objects, leading to the ability to remotely execute arbitrary code. This is known as an “insecure deserialization” vulnerability, or “gadget vulnerability”. Ratpack allows session data to be stored server side in an external system such as a relational database, or client side via user cookies. When using server side storage, the attacker would need to obtain the ability to write to the session data store. When using client side storage, the attacker would need to obtain the secrets used to encrypt and/or sign the session data stored in user cookies. Ratpack's session mechanism allows storing serialized objects, of…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-hc33-32vw-rpp9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-29485

Advisory: Remote Code Execution Vulnerability in Session Storage
IDs: CVE-2021-29485, GHSA-hc33-32vw-rpp9
Record: https://patchnext.com/advisories/cve-2021-29485 (revision 1, source checked 26 Oct 2026, 16:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: io.ratpack:ratpack-core 1.9.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven io.ratpack:ratpack-core: affected < 1.9.0; fixed in 1.9.0

## Suggested inspection (read-only)
- Maven io.ratpack:ratpack-core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on io.ratpack:ratpack-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hc33-32vw-rpp9 (GitHub-reviewed advisory GHSA-hc33-32vw-rpp9 lists affected ranges: Maven io.ratpack:ratpack-core >=0 <1.9.0)

Commands are suggestions: review each one before running it.

Loading voting…