DOM XSS in Theme Preview
CVE-2021-29484GHSA-9fgx-q25h-jxrg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ghost 4.3.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm ghost
- Affected
- >= 4.0.0, < 4.3.3
- Fixed in
- 4.3.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9fgx-q25h-jxrg lists affected ranges: npm ghost >=4.0.0 <4.3.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9fgx-q25h-jxrg lists affected ranges: npm ghost >=4.0.0 <4.3.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N
- EPSS
- CVE-2021-29484: 7.94% estimated exploitation activity in the next 30 days; percentile 94.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An unused endpoint added during the development of 4.0.0 has left sites vulnerable to untrusted users gaining access to Ghost Admin. Attackers can gain access by getting logged in users to click a link containing malicious code. Users do not need to enter credentials and may not know they've visited a malicious site. Ghost(Pro) has already been patched. We can find no evidence that the issue was exploited on Ghost(Pro) prior to the patch being added. Self-hosters are impacted if running Ghost a version between 4.0.0 and 4.3.2. Immediate action should be taken to secure your site - see patches & workarounds below. Patches Fixed in 4.3.3, all 4.x sites should upgrade as soon as possible. As the endpoint is unused, the patch simply removes it. Workarounds - Log out of Ghost Admin - Suspend any users who cannot log out - Block access to /ghost/preview Example of how to block access in nginx: This redirects the endpoint to /ghost/, which mimics the behaviour after the patch is…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-9fgx-q25h-jxrg
- Revision 1 · created ·
Published from osv record GHSA-9fgx-q25h-jxrg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-29484 Advisory: DOM XSS in Theme Preview IDs: CVE-2021-29484, GHSA-9fgx-q25h-jxrg Record: https://patchnext.com/advisories/cve-2021-29484 (revision 2, source checked 26 Oct 2026, 12:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ghost 4.3.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm ghost: affected >= 4.0.0, < 4.3.3; fixed in 4.3.3 ## Suggested inspection (read-only) - `npm ls ghost --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ghost. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9fgx-q25h-jxrg (OSV record GHSA-9fgx-q25h-jxrg lists affected ranges: npm ghost >=4.0.0 <4.3.3 (fixed)) - Verified: https://github.com/advisories/GHSA-9fgx-q25h-jxrg (GitHub-reviewed advisory GHSA-9fgx-q25h-jxrg lists affected ranges: npm ghost >=4.0.0 <4.3.3) Commands are suggestions: review each one before running it.
Loading voting…