Composer's missing argument delimiter can lead to code execution via VCS repository URLs or source download URLs on systems with Mercurial
CVE-2021-29472GHSA-h5h8-pc6h-jvvx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (composer/composer 2.0.13, 1.10.22), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist composer/composer
- Affected
- < 1.10.22>= 2.0.0-alpha1, < 2.0.13
- Fixed in
- 2.0.13, 1.10.22
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h5h8-pc6h-jvvx lists affected ranges: Packagist composer/composer >=0 =2.0.0-alpha1 <2.0.13
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2021-29472: 4.75% estimated exploitation activity in the next 30 days; percentile 91.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
URLs for Mercurial repositories in the root composer.json and package source download URLs are not sanitized correctly. Specifically crafted URL values allow commands to be executed in the HgDriver if hg/Mercurial is installed on the system. Impact - The impact to Composer users directly is limited as the composer.json file is typically under their own control and source download URLs can only be supplied by third party Composer repositories they explicitly trust to download and execute source code from, e.g. Composer plugins. - The main impact is to services passing user input to Composer, including Packagist.org and Private Packagist. This allowed users to trigger remote command injection. The vulnerability has been patched on Packagist.org and Private Packagist within 12h of receiving the initial vulnerability report and based on a review of logs, to the best of our knowledge, was not abused by anyone. - Other services/tools using VcsRepository/VcsDriver or derivatives may also be…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-h5h8-pc6h-jvvx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-29472 Advisory: Composer's missing argument delimiter can lead to code execution via VCS repository URLs or source download URLs on systems with Mercurial IDs: CVE-2021-29472, GHSA-h5h8-pc6h-jvvx Record: https://patchnext.com/advisories/cve-2021-29472 (revision 1, source checked 26 Oct 2026, 14:14 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: composer/composer 2.0.13, 1.10.22. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist composer/composer: affected < 1.10.22; >= 2.0.0-alpha1, < 2.0.13; fixed in 2.0.13, 1.10.22 ## Suggested inspection (read-only) - Packagist composer/composer: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on composer/composer. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-h5h8-pc6h-jvvx (GitHub-reviewed advisory GHSA-h5h8-pc6h-jvvx lists affected ranges: Packagist composer/composer >=0 =2.0.0-alpha1 <2.0.13) Commands are suggestions: review each one before running it.
Loading voting…