Skip to content

← Actionable
Medium, CVSS 6.3amended

Denial of service attack via push rule patterns in matrix-synapse

CVE-2021-29471GHSA-x345-32rc-8h85

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (matrix-synapse 1.33.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2021-29471: 1.65% estimated exploitation activity in the next 30 days; percentile 76.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact "Push rules" can specify conditions under which they will match, including eventmatch, which matches event content against a pattern including wildcards. Certain patterns can cause very poor performance in the matching engine, leading to a denial-of-service when processing moderate length events. Patches The issue is patched by https://github.com/matrix-org/synapse/commit/03318a766cac9f8b053db2214d9c332a977d226c. Workarounds A potential workaround might be to prevent users from making custom push rules, by blocking such requests at a reverse-proxy. For more information If you have any questions or comments about this advisory, email us at security@matrix.org.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-x345-32rc-8h85

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-x345-32rc-8h85

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-29471

Advisory: Denial of service attack via push rule patterns in matrix-synapse
IDs: CVE-2021-29471, GHSA-x345-32rc-8h85
Record: https://patchnext.com/advisories/cve-2021-29471 (revision 3, source checked 26 Oct 2026, 13:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: matrix-synapse 1.33.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI matrix-synapse: affected < 1.33.2; fixed in 1.33.2

## Suggested inspection (read-only)
- `python -m pip show matrix-synapse`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on matrix-synapse.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-x345-32rc-8h85 (OSV record GHSA-x345-32rc-8h85 lists affected ranges: PyPI matrix-synapse >=0 <1.33.2 (fixed))
- Verified: https://github.com/advisories/GHSA-x345-32rc-8h85 (GitHub-reviewed advisory GHSA-x345-32rc-8h85 lists affected ranges: PyPI matrix-synapse >=0 <1.33.2)

Commands are suggestions: review each one before running it.

Loading voting…