Skip to content

← Actionable
High, CVSS 7.6

Cross-site scripting (XSS) from unsanitized uploaded SVG files in Kirby

CVE-2021-29460GHSA-qgp4-5qx6-548g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (getkirby/cms 3.5.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.6 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:N
EPSS
  • CVE-2021-29460: 3.17% estimated exploitation activity in the next 30 days; percentile 88.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An editor with write access to the Kirby Panel can upload an SVG or XML file that contains harmful content like <script tags. The direct link to that file can be sent to other users or visitors of the site. If the victim opens that link in a browser where they are logged in to Kirby, the script will run and can for example trigger requests to Kirby's API with the permissions of the victim. This vulnerability is critical if you might have potential attackers in your group of authenticated Panel users. They can escalate their privileges if they get access to the Panel session of an admin user. Depending on your site, other JavaScript-powered attacks are possible. Visitors without Panel access can only use this attack vector if your site allows SVG or XML file uploads in frontend forms and you don't already validate or sanitize uploaded SVG or XML files. The attack requires user interaction by another user or visitor and cannot be automated. Patches Uploads in the Panel The…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-qgp4-5qx6-548g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-29460

Advisory: Cross-site scripting (XSS) from unsanitized uploaded SVG files in Kirby
IDs: CVE-2021-29460, GHSA-qgp4-5qx6-548g
Record: https://patchnext.com/advisories/cve-2021-29460 (revision 1, source checked 26 Oct 2026, 14:01 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: getkirby/cms 3.5.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist getkirby/cms: affected < 3.5.4; fixed in 3.5.4

## Suggested inspection (read-only)
- Packagist getkirby/cms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on getkirby/cms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qgp4-5qx6-548g (GitHub-reviewed advisory GHSA-qgp4-5qx6-548g lists affected ranges: Packagist getkirby/cms >=0 <3.5.4)

Commands are suggestions: review each one before running it.

Loading voting…