Skip to content

← Actionable
Medium, CVSS 5.9amended

Padding Oracle Attack due to Observable Timing Discrepancy in jose-node-esm-runtime

CVE-2021-29445GHSA-4v4g-726h-xvfv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (jose-node-esm-runtime 3.11.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2021-29445: 1.07% estimated exploitation activity in the next 30 days; percentile 64.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact AESCBCHMACSHA2 Algorithm (A128CBC-HS256, A192CBC-HS384, A256CBC-HS512) decryption would always execute both HMAC tag verification and CBC decryption, if either failed JWEDecryptionFailed would be thrown. But a possibly observable difference in timing when padding error would occur while decrypting the ciphertext makes a padding oracle and an adversary might be able to make use of that oracle to decrypt data without knowing the decryption key by issuing on average 128b calls to the padding oracle (where b is the number of bytes in the ciphertext block). Patches A patch was released which ensures the HMAC tag is verified before performing CBC decryption. The fixed versions are =3.11.4. Users should upgrade to ^3.11.4. Credits Thanks to Morgan Brown of Microsoft for bringing this up and Eva Sarafianou (@esarafianou) for helping to score this advisory.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-4v4g-726h-xvfv

  2. Revision 1 · created ·

    Published from osv record GHSA-4v4g-726h-xvfv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-29445

Advisory: Padding Oracle Attack due to Observable Timing Discrepancy in jose-node-esm-runtime
IDs: CVE-2021-29445, GHSA-4v4g-726h-xvfv
Record: https://patchnext.com/advisories/cve-2021-29445 (revision 2, source checked 26 Oct 2026, 12:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: jose-node-esm-runtime 3.11.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm jose-node-esm-runtime: affected < 3.11.4; fixed in 3.11.4

## Suggested inspection (read-only)
- `npm ls jose-node-esm-runtime --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on jose-node-esm-runtime.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4v4g-726h-xvfv (OSV record GHSA-4v4g-726h-xvfv lists affected ranges: npm jose-node-esm-runtime >=0 <3.11.4 (fixed))
- Verified: https://github.com/advisories/GHSA-4v4g-726h-xvfv (GitHub-reviewed advisory GHSA-4v4g-726h-xvfv lists affected ranges: npm jose-node-esm-runtime >=0 <3.11.4)

Commands are suggestions: review each one before running it.

Loading voting…