Skip to content

← Actionable
Unrated

Authentication bypass for specific endpoint

CVE-2021-29442GHSA-xv5h-v7jh-p2qh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.alibaba.nacos:nacos-common 1.4.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2021-29442: 65.72% estimated exploitation activity in the next 30 days; percentile 99.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The ConfigOpsController lets the user perform management operations like querying the database or even wiping it out. While the /data/remove endpoint is properly protected with the @Secured annotation, the /derby endpoint is not protected and can be openly accessed by unauthenticated users. For example, the following request will list the tables of the database: These endpoints are only valid when using embedded storage (derby DB) so this issue should not affect those installations using external storage (e.g. mysql)

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-xv5h-v7jh-p2qh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-29442

Advisory: Authentication bypass for specific endpoint
IDs: CVE-2021-29442, GHSA-xv5h-v7jh-p2qh
Record: https://patchnext.com/advisories/cve-2021-29442 (revision 1, source checked 26 Oct 2026, 16:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: com.alibaba.nacos:nacos-common 1.4.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven com.alibaba.nacos:nacos-common: affected < 1.4.1; fixed in 1.4.1

## Suggested inspection (read-only)
- Maven com.alibaba.nacos:nacos-common: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on com.alibaba.nacos:nacos-common.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-xv5h-v7jh-p2qh (GitHub-reviewed advisory GHSA-xv5h-v7jh-p2qh lists affected ranges: Maven com.alibaba.nacos:nacos-common >=0 <1.4.1)

Commands are suggestions: review each one before running it.

Loading voting…