Grav's Twig processing allowing dangerous PHP functions by default
CVE-2021-29440GHSA-g8r4-p96j-xfxc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (getgrav/grav 1.7.11), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist getgrav/grav
- Affected
- <= 1.7.10
- Fixed in
- 1.7.11
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g8r4-p96j-xfxc lists affected ranges: Packagist getgrav/grav >=0 <=1.7.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.4 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H
- EPSS
- CVE-2021-29440: 29.90% estimated exploitation activity in the next 30 days; percentile 98.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Twig processing of static pages can be enabled in the front matter by any administrative user allowed to create or edit pages. As the Twig processor runs unsandboxed, this behavior can be used to gain arbitrary code execution and elevate privileges on the instance. Patches The issue was addressed by preventing dangerous functions from being called in Twig templates. A configuration option has been added to manually allow arbitrary PHP functions (system.twig.safefunctions) and filters (system.twig.safefilters). Futures major versions of Grav may disable this functionality by default. Workarounds Blocking access to the /admin path from untrusted sources will reduce the probability of exploitation. References - https://portswigger.net/research/server-side-template-injection - https://blog.sonarsource.com/grav-cms-code-execution-vulnerabilities For more information If you have any questions or comments about this advisory, you can contact: - The original reporters, by sending an…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-g8r4-p96j-xfxc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-29440 Advisory: Grav's Twig processing allowing dangerous PHP functions by default IDs: CVE-2021-29440, GHSA-g8r4-p96j-xfxc Record: https://patchnext.com/advisories/cve-2021-29440 (revision 1, source checked 26 Oct 2026, 14:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: getgrav/grav 1.7.11. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist getgrav/grav: affected <= 1.7.10; fixed in 1.7.11 ## Suggested inspection (read-only) - Packagist getgrav/grav: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on getgrav/grav. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-g8r4-p96j-xfxc (GitHub-reviewed advisory GHSA-g8r4-p96j-xfxc lists affected ranges: Packagist getgrav/grav >=0 <=1.7.10) Commands are suggestions: review each one before running it.
Loading voting…