Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) in @nextcloud/dialogs
CVE-2021-29438GHSA-g3fq-3v3g-mh32
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@nextcloud/dialogs 3.1.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 3.1.2
- Fixed in
- 3.1.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-g3fq-3v3g-mh32 lists affected ranges: npm @nextcloud/dialogs >=0 <3.1.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g3fq-3v3g-mh32 lists affected ranges: npm @nextcloud/dialogs >=0 <3.1.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.6 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N
- EPSS
- CVE-2021-29438: 0.70% estimated exploitation activity in the next 30 days; percentile 53.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The Nextcloud dialogs library before 3.1.2 did insufficiently escape text input passed to a toast. If your application displays toasts with user-supplied input, this could lead to a XSS vulnerability. Note: Nextcloud Server employs a strict Content Security Policy that mitigates the risk of these XSS vulnerabilities. Patches The vulnerability has been patched in version 3.1.2. If you need to display HTML in the toast, explicitly pass the options.isHTML config flag. Workarounds Make sure no user-supplied input flows into toasts.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-g3fq-3v3g-mh32
- Revision 1 · created ·
Published from osv record GHSA-g3fq-3v3g-mh32
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-29438 Advisory: Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) in @nextcloud/dialogs IDs: CVE-2021-29438, GHSA-g3fq-3v3g-mh32 Record: https://patchnext.com/advisories/cve-2021-29438 (revision 2, source checked 26 Oct 2026, 12:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @nextcloud/dialogs 3.1.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @nextcloud/dialogs: affected < 3.1.2; fixed in 3.1.2 ## Suggested inspection (read-only) - `npm ls @nextcloud/dialogs --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @nextcloud/dialogs. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-g3fq-3v3g-mh32 (OSV record GHSA-g3fq-3v3g-mh32 lists affected ranges: npm @nextcloud/dialogs >=0 <3.1.2 (fixed)) - Verified: https://github.com/advisories/GHSA-g3fq-3v3g-mh32 (GitHub-reviewed advisory GHSA-g3fq-3v3g-mh32 lists affected ranges: npm @nextcloud/dialogs >=0 <3.1.2) Commands are suggestions: review each one before running it.
Loading voting…