Improper validation of URLs ('Cross-site Scripting') in Wagtail rich text fields
CVE-2021-29434GHSA-wq5h-f9p5-q7fx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (wagtail 2.12.4, 2.11.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI wagtail
- Affected
- >= 2.12, <= 2.12.3<= 2.11.6
- Fixed in
- 2.11.7, 2.12.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-wq5h-f9p5-q7fx lists affected ranges: PyPI wagtail >=0 =2.12 <2.12.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wq5h-f9p5-q7fx lists affected ranges: PyPI wagtail >=2.12 =0 <=2.11.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2021-29434: 0.63% estimated exploitation activity in the next 30 days; percentile 50.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact When saving the contents of a rich text field in the admin interface, Wagtail does not apply server-side checks to ensure that link URLs use a valid protocol. A malicious user with access to the admin interface could thus craft a POST request to publish content with javascript: URLs containing arbitrary code. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin. Patches Patched versions have been released as Wagtail 2.11.7 (for the LTS 2.11 branch) and Wagtail 2.12.4 (for the current 2.12 branch). Workarounds For sites that cannot easily upgrade to a current supported version, the vulnerability can be patched by adding the following code to a wagtailhooks.py module in any installed app: Acknowledgements Many thanks to Kevin Breen for reporting this issue. For more information If you have any questions or comments about this advisory: Visit Wagtail's support channels Email us at security@wagtail.io (if you wish to send encrypted…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-wq5h-f9p5-q7fx
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-wq5h-f9p5-q7fx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-29434
Advisory: Improper validation of URLs ('Cross-site Scripting') in Wagtail rich text fields
IDs: CVE-2021-29434, GHSA-wq5h-f9p5-q7fx
Record: https://patchnext.com/advisories/cve-2021-29434 (revision 3, source checked 26 Oct 2026, 13:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: wagtail 2.12.4, 2.11.7. A vendor fix does not mean a deployment is fixed.
## Affected components
- PyPI wagtail: affected >= 2.12, <= 2.12.3; <= 2.11.6; fixed in 2.11.7, 2.12.4
## Suggested inspection (read-only)
- `python -m pip show wagtail`: prints the installed version. Run with the environment that serves production active.
## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.
## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on wagtail.
- Repeat the inspection and confirm that only fixed versions remain installed.
## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.
## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.
## Sources
- Verified: https://osv.dev/vulnerability/GHSA-wq5h-f9p5-q7fx (OSV record GHSA-wq5h-f9p5-q7fx lists affected ranges: PyPI wagtail >=0 =2.12 <2.12.4 (fixed))
- Verified: https://github.com/advisories/GHSA-wq5h-f9p5-q7fx (GitHub-reviewed advisory GHSA-wq5h-f9p5-q7fx lists affected ranges: PyPI wagtail >=2.12 =0 <=2.11.6)
Commands are suggestions: review each one before running it.Loading voting…