Sydent vulnerable to denial of service attack via memory exhaustion
CVE-2021-29430GHSA-wmg4-8cp2-hpg9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (matrix-sydent 2.3.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI matrix-sydent
- Affected
- < 2.3.0
- Fixed in
- 2.3.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-wmg4-8cp2-hpg9 lists affected ranges: PyPI matrix-sydent >=0 <2.3.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wmg4-8cp2-hpg9 lists affected ranges: PyPI matrix-sydent >=0 <2.3.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2021-29430: 1.83% estimated exploitation activity in the next 30 days; percentile 78.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Sydent does not limit the size of requests it receives from HTTP clients. A malicious user could send an HTTP request with a very large body, leading to disk space exhaustion and denial of service. Sydent also does not limit response size for requests it makes to remote Matrix homeservers. A malicious homeserver could return a very large response, again leading to memory exhaustion and denial of service. This affects any server which accepts registration requests from untrusted clients. Patches Patched by 89071a1, 0523511, f56eee3. Workarounds Request sizes can be limited in an HTTP reverse-proxy. There are no known workarounds for the problem with overlarge responses. For more information If you have any questions or comments about this advisory, email us at security@matrix.org.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-wmg4-8cp2-hpg9
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-wmg4-8cp2-hpg9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-29430 Advisory: Sydent vulnerable to denial of service attack via memory exhaustion IDs: CVE-2021-29430, GHSA-wmg4-8cp2-hpg9 Record: https://patchnext.com/advisories/cve-2021-29430 (revision 3, source checked 26 Oct 2026, 13:17 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: matrix-sydent 2.3.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI matrix-sydent: affected < 2.3.0; fixed in 2.3.0 ## Suggested inspection (read-only) - `python -m pip show matrix-sydent`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on matrix-sydent. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-wmg4-8cp2-hpg9 (OSV record GHSA-wmg4-8cp2-hpg9 lists affected ranges: PyPI matrix-sydent >=0 <2.3.0 (fixed)) - Verified: https://github.com/advisories/GHSA-wmg4-8cp2-hpg9 (GitHub-reviewed advisory GHSA-wmg4-8cp2-hpg9 lists affected ranges: PyPI matrix-sydent >=0 <2.3.0) Commands are suggestions: review each one before running it.
Loading voting…