Skip to content

← Actionable
Medium, CVSS 4.8

Path Traversal and Improper Input Validation in Apache Commons IO

CVE-2021-29425GHSA-gwrp-pvrq-jmwv

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven net.hasor:cobble-lang

    Affected
    >= 4.4.1, <= 4.6.2
    Fixed in
    no fixed version recorded
  • Maven org.checkerframework.annotatedlib:commons-io

    Affected
    >= 2.6, < 2.7
    Fixed in
    2.7
  • Maven org.apache.servicemix.bundles:org.apache.servicemix.bundles.commons-io

    Affected
    >= 1.4, <= 1.5
    Fixed in
    no fixed version recorded
  • Maven com.diamondq.common:common-thirdparty.jcasbin

    Affected
    >= 1.4.0, <= 1.4.0
    Fixed in
    no fixed version recorded
  • Maven com.liferay:com.liferay.sass.compiler.jsass

    Affected
    >= 1.0.1, <= 1.0.1
    Fixed in
    no fixed version recorded
  • Maven org.smartboot.servlet:servlet-core

    Affected
    >= 0.1.9, <= 0.6
    Fixed in
    no fixed version recorded
  • Maven com.cosium.vet:vet

    Affected
    >= 1.0, <= 3.22
    Fixed in
    no fixed version recorded
  • Maven commons-io:commons-io

    Affected
    < 2.7
    Fixed in
    2.7
  • Maven org.apache.commons:commons-io

    Affected
    >= 1.3.2, <= 1.3.2
    Fixed in
    no fixed version recorded
  • Maven com.virjar:ratel-api

    Affected
    >= 1.0.0, <= 1.3.6
    Fixed in
    no fixed version recorded

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-gwrp-pvrq-jmwv lists affected ranges: Maven commons-io:commons-io >=0 =1.0 =1.4.0 =1.0.1 =1.0.0 =4.4.1 =1.3.2 <=1.3.2; Maven…

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2021-29425: 10.55% estimated exploitation activity in the next 30 days; percentile 95.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In Apache Commons IO before 2.7, When invoking the method FileNameUtils.normalize with an improper input string, like "//../foo", or "\\..\foo", the result would be the same value, thus possibly providing access to files in the parent directory, but not further above (thus "limited" path traversal), if the calling code would use the result to construct a path value.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-gwrp-pvrq-jmwv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-29425

Advisory: Path Traversal and Improper Input Validation in Apache Commons IO
IDs: CVE-2021-29425, GHSA-gwrp-pvrq-jmwv
Record: https://patchnext.com/advisories/cve-2021-29425 (revision 1, source checked 26 Oct 2026, 16:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: org.checkerframework.annotatedlib:commons-io 2.7; commons-io:commons-io 2.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven net.hasor:cobble-lang: affected >= 4.4.1, <= 4.6.2
- Maven org.checkerframework.annotatedlib:commons-io: affected >= 2.6, < 2.7; fixed in 2.7
- Maven org.apache.servicemix.bundles:org.apache.servicemix.bundles.commons-io: affected >= 1.4, <= 1.5
- Maven com.diamondq.common:common-thirdparty.jcasbin: affected >= 1.4.0, <= 1.4.0
- Maven com.liferay:com.liferay.sass.compiler.jsass: affected >= 1.0.1, <= 1.0.1
- Maven org.smartboot.servlet:servlet-core: affected >= 0.1.9, <= 0.6
- Maven com.cosium.vet:vet: affected >= 1.0, <= 3.22
- Maven commons-io:commons-io: affected < 2.7; fixed in 2.7
- Maven org.apache.commons:commons-io: affected >= 1.3.2, <= 1.3.2
- Maven com.virjar:ratel-api: affected >= 1.0.0, <= 1.3.6

## Suggested inspection (read-only)
- Maven net.hasor:cobble-lang: check the installed version with your package manager.
- Maven org.checkerframework.annotatedlib:commons-io: check the installed version with your package manager.
- Maven org.apache.servicemix.bundles:org.apache.servicemix.bundles.commons-io: check the installed version with your package manager.
- Maven com.diamondq.common:common-thirdparty.jcasbin: check the installed version with your package manager.
- Maven com.liferay:com.liferay.sass.compiler.jsass: check the installed version with your package manager.
- Maven org.smartboot.servlet:servlet-core: check the installed version with your package manager.
- Maven com.cosium.vet:vet: check the installed version with your package manager.
- Maven commons-io:commons-io: check the installed version with your package manager.
- Maven org.apache.commons:commons-io: check the installed version with your package manager.
- Maven com.virjar:ratel-api: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on net.hasor:cobble-lang, org.checkerframework.annotatedlib:commons-io, org.apache.servicemix.bundles:org.apache.servicemix.bundles.commons-io, com.diamondq.common:common-thirdparty.jcasbin, com.liferay:com.liferay.sass.compiler.jsass, org.smartboot.servlet:servlet-core, com.cosium.vet:vet, commons-io:commons-io, org.apache.commons:commons-io, com.virjar:ratel-api.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gwrp-pvrq-jmwv (GitHub-reviewed advisory GHSA-gwrp-pvrq-jmwv lists affected ranges: Maven commons-io:commons-io >=0 =1.0 =1.4.0 =1.0.1 =1.0.0 =4.4.1 =1.3.2 <=1.3.2; Maven…)

Commands are suggestions: review each one before running it.

Loading voting…