Improper input validation in umoci
CVE-2021-29136GHSA-9m95-8hx6-7p9v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/opencontainers/umoci 0.4.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/opencontainers/umoci
- Affected
- < 0.4.7
- Fixed in
- 0.4.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9m95-8hx6-7p9v lists affected ranges: Go github.com/opencontainers/umoci >=0 <0.4.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.5 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2021-29136: 0.34% estimated exploitation activity in the next 30 days; percentile 27.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact umoci 0.4.6 and earlier can be tricked into modifying host files by creating a malicious layer that has a symlink with the name "." (or "/"). Because umoci deletes inodes if they change types, this results in the rootfs directory being replaced with an attacker-controlled symlink. Subsequent image layers will then be applied on top of the target of the symlink (which could be any directory on the host filesystem the user running umoci has access to). While umoci does have defences against symlink-based attacks, they are all implemented by resolving things relative to the rootfs directory -- if the rootfs itself is a symlink, umoci resolves it first. This vulnerability affects both "umoci unpack" and "umoci raw unpack". Patches This issue has been patched in umoci 0.4.7, see the references section for the specific commit which fixed this vulnerability. Workarounds Note that if you use umoci as an unprivileged user (using the --rootless flag) then umoci will not be able to…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9m95-8hx6-7p9v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-29136 Advisory: Improper input validation in umoci IDs: CVE-2021-29136, GHSA-9m95-8hx6-7p9v Record: https://patchnext.com/advisories/cve-2021-29136 (revision 1, source checked 26 Oct 2026, 14:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/opencontainers/umoci 0.4.7. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/opencontainers/umoci: affected < 0.4.7; fixed in 0.4.7 ## Suggested inspection (read-only) - Go github.com/opencontainers/umoci: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/opencontainers/umoci. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9m95-8hx6-7p9v (GitHub-reviewed advisory GHSA-9m95-8hx6-7p9v lists affected ranges: Go github.com/opencontainers/umoci >=0 <0.4.7) Commands are suggestions: review each one before running it.
Loading voting…