Jetty Utility Servlets ConcatServlet Double Decoding Information Disclosure Vulnerability
CVE-2021-28169GHSA-gwcr-j4wh-j3cq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.eclipse.jetty:jetty-servlets 11.0.3, 10.0.3, 9.4.41), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.eclipse.jetty:jetty-servlets
- Affected
- <= 9.4.40>= 10.0.0, <= 10.0.2>= 11.0.0, <= 11.0.2
- Fixed in
- 9.4.41, 11.0.3, 10.0.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gwcr-j4wh-j3cq lists affected ranges: Maven org.eclipse.jetty:jetty-servlets >=0 =10.0.0 =11.0.0 <=11.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2021-28169: 78.48% estimated exploitation activity in the next 30 days; percentile 99.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Requests to the ConcatServlet and WelcomeFilter are able to access protected resources within the WEB-INF directory. For example a request to the ConcatServlet with a URI of /concat?/%2557EB-INF/web.xml can retrieve the web.xml file. This can reveal sensitive information regarding the implementation of a web application. This occurs because both ConcatServlet and WelcomeFilter decode the supplied path to verify it is not within the WEB-INF or META-INF directories. It then uses this decoded path to call RequestDispatcher which will also do decoding of the path. This double decoding allows paths with a doubly encoded WEB-INF to bypass this security check. Impact This affects all versions of ConcatServlet and WelcomeFilter in versions before 9.4.41, 10.0.3 and 11.0.3. Workarounds If you cannot update to the latest version of Jetty, you can instead deploy your own version of the ConcatServlet and/or the WelcomeFilter by using the code from the latest version of Jetty.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-gwcr-j4wh-j3cq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-28169 Advisory: Jetty Utility Servlets ConcatServlet Double Decoding Information Disclosure Vulnerability IDs: CVE-2021-28169, GHSA-gwcr-j4wh-j3cq Record: https://patchnext.com/advisories/cve-2021-28169 (revision 1, source checked 26 Oct 2026, 16:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.eclipse.jetty:jetty-servlets 11.0.3, 10.0.3, 9.4.41. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.eclipse.jetty:jetty-servlets: affected <= 9.4.40; >= 10.0.0, <= 10.0.2; >= 11.0.0, <= 11.0.2; fixed in 9.4.41, 11.0.3, 10.0.3 ## Suggested inspection (read-only) - Maven org.eclipse.jetty:jetty-servlets: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.eclipse.jetty:jetty-servlets. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-gwcr-j4wh-j3cq (GitHub-reviewed advisory GHSA-gwcr-j4wh-j3cq lists affected ranges: Maven org.eclipse.jetty:jetty-servlets >=0 =10.0.0 =11.0.0 <=11.0.2) Commands are suggestions: review each one before running it.
Loading voting…