Skip to content

← Actionable
High, CVSS 7.2

Mautic vulnerable to Relative Path Traversal / Arbitrary File Deletion due to GrapesJS builder

CVE-2021-27916GHSA-9fcx-cv56-w58p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mautic/core 5.0.4, 4.4.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist mautic/core

    Affected
    >= 3.3.0, < 4.4.12>= 5.0.0-alpha, < 5.0.4
    Fixed in
    5.0.4, 4.4.12

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.2 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2021-27916: 0.80% estimated exploitation activity in the next 30 days; percentile 56.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Prior to the patched version, logged in users of Mautic are vulnerable to Relative Path Traversal/Arbitrary File Deletion. Regardless of the level of access the Mautic user had, they could delete files other than those in the media folders such as system files, libraries or other important files. This vulnerability exists in the implementation of the GrapesJS builder in Mautic. Patches Update to 4.4.12 or 5.0.4. Workarounds No References - https://cwe.mitre.org/data/definitions/23.html - https://cwe.mitre.org/data/definitions/22.html - https://attack.mitre.org/techniques/T1630/002/ For more information If you have any questions or comments about this advisory: Email us at security@mautic.org

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9fcx-cv56-w58p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-27916

Advisory: Mautic vulnerable to Relative Path Traversal / Arbitrary File Deletion due to GrapesJS builder
IDs: CVE-2021-27916, GHSA-9fcx-cv56-w58p
Record: https://patchnext.com/advisories/cve-2021-27916 (revision 1, source checked 26 Oct 2026, 14:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mautic/core 5.0.4, 4.4.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist mautic/core: affected >= 3.3.0, < 4.4.12; >= 5.0.0-alpha, < 5.0.4; fixed in 5.0.4, 4.4.12

## Suggested inspection (read-only)
- Packagist mautic/core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mautic/core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9fcx-cv56-w58p (GitHub-reviewed advisory GHSA-9fcx-cv56-w58p lists affected ranges: Packagist mautic/core >=3.3.0 =5.0.0-alpha <5.0.4)

Commands are suggestions: review each one before running it.

Loading voting…