Use of a Broken or Risky Cryptographic Algorithm
CVE-2021-27913GHSA-x7g2-wrrp-r6h3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mautic/core 4.0.0, 3.3.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist mautic/core
- Affected
- < 3.3.4>= 4.0.0-alpha1, < 4.0.0
- Fixed in
- 4.0.0, 3.3.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x7g2-wrrp-r6h3 lists affected ranges: Packagist mautic/core >=0 =4.0.0-alpha1 <4.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:L
- EPSS
- CVE-2021-27913: 0.46% estimated exploitation activity in the next 30 days; percentile 39.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
✍️ Description The function mtrand is used to generate session tokens, this function is cryptographically flawed due to its nature being one pseudorandomness, an attacker can take advantage of the cryptographically insecure nature of this function to enumerate session tokens for accounts that are not under his/her control 🕵️♂️ Proof of Concept Numerous examples and attack implementations can be found in this paper . If you're looking for a practical tool that can crack your mtrand implementation's seed value, see this project and run the following commands in a console with php5 and OpenWall's tool installed: root$ php -r 'mtsrand(13333337); echo mtrand( ), "\n";' After that, copy the output (1863134308) and execute the following commands: root$ gcc phpmtseed.c -o phpmtseedroot$ ./phpmtseed 1863134308 After waiting ~1 minute you should have a few possible seeds corresponding to their PHP versions, next to your installed PHP version you should see something akin to: seed =…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-x7g2-wrrp-r6h3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-27913 Advisory: Use of a Broken or Risky Cryptographic Algorithm IDs: CVE-2021-27913, GHSA-x7g2-wrrp-r6h3 Record: https://patchnext.com/advisories/cve-2021-27913 (revision 1, source checked 26 Oct 2026, 14:15 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mautic/core 4.0.0, 3.3.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist mautic/core: affected < 3.3.4; >= 4.0.0-alpha1, < 4.0.0; fixed in 4.0.0, 3.3.4 ## Suggested inspection (read-only) - Packagist mautic/core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mautic/core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-x7g2-wrrp-r6h3 (GitHub-reviewed advisory GHSA-x7g2-wrrp-r6h3 lists affected ranges: Packagist mautic/core >=0 =4.0.0-alpha1 <4.0.0) Commands are suggestions: review each one before running it.
Loading voting…