Skip to content

← Actionable
Medium, CVSS 6.3

XSS vulnerability on password reset page

CVE-2021-27909GHSA-32hw-3pvh-vcvc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mautic/core 4.0.0, 3.3.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist mautic/core

    Affected
    < 3.3.4>= 4.0.0-alpha1, < 4.0.0
    Fixed in
    4.0.0, 3.3.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L
EPSS
  • CVE-2021-27909: 4.07% estimated exploitation activity in the next 30 days; percentile 90.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact For Mautic versions prior to 3.3.4, there is an XSS vulnerability on Mautic's password reset page where a vulnerable parameter, "bundle," in the URL could allow an attacker to execute Javascript code. The attacker would be required to convince or trick the target into clicking a password reset URL with the vulnerable parameter utilized. Patches Upgrade to 3.3.4 or 4.0.0 Workarounds No References https://github.com/mautic/mautic/releases/tag/3.3.4 https://github.com/mautic/mautic/releases/tag/4.0.0 For more information If you have any questions or comments about this advisory: Email us at security@mautic.org

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-32hw-3pvh-vcvc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-27909

Advisory: XSS vulnerability on password reset page
IDs: CVE-2021-27909, GHSA-32hw-3pvh-vcvc
Record: https://patchnext.com/advisories/cve-2021-27909 (revision 1, source checked 26 Oct 2026, 14:15 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mautic/core 4.0.0, 3.3.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist mautic/core: affected < 3.3.4; >= 4.0.0-alpha1, < 4.0.0; fixed in 4.0.0, 3.3.4

## Suggested inspection (read-only)
- Packagist mautic/core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mautic/core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-32hw-3pvh-vcvc (GitHub-reviewed advisory GHSA-32hw-3pvh-vcvc lists affected ranges: Packagist mautic/core >=0 =4.0.0-alpha1 <4.0.0)

Commands are suggestions: review each one before running it.

Loading voting…