Mautic vulnerable to secret data exfiltration via symfony parameters
CVE-2021-27908GHSA-4hjq-422q-4vpx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mautic/core 3.3.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist mautic/core
- Affected
- < 3.3.2
- Fixed in
- 3.3.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4hjq-422q-4vpx lists affected ranges: Packagist mautic/core >=0 <3.3.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.8 · CVSS:3.1/AV:L/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:L
- EPSS
- CVE-2021-27908: 0.34% estimated exploitation activity in the next 30 days; percentile 28.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Symfony parameters (which is what Mautic transforms configuration parameters into) can be used within other Symfony parameters by design. However, this also means that an admin who is normally not privy to certain parameters, such as database credentials, could expose them by leveraging any of the free text fields in Mautic’s configuration that are used in publicly facing parts of the application. For example, 1. Go to Configuration page - Landing Page Settings - Analytics script and enter this: <script console.log("db password is: %mautic.dbpassword%"); </script 2. Visit any landing page and open the JS dev console. You will see the following message with real instance db password: db password is: <real password Risk rating: ModerateCVSS:3.1/AV:L/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:L Patches Upgrade to 3.3.2 Workarounds No References No For more information If you have any questions or comments about this advisory: Email us at security@mautic.org
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4hjq-422q-4vpx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-27908 Advisory: Mautic vulnerable to secret data exfiltration via symfony parameters IDs: CVE-2021-27908, GHSA-4hjq-422q-4vpx Record: https://patchnext.com/advisories/cve-2021-27908 (revision 1, source checked 26 Oct 2026, 14:15 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mautic/core 3.3.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist mautic/core: affected < 3.3.2; fixed in 3.3.2 ## Suggested inspection (read-only) - Packagist mautic/core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mautic/core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4hjq-422q-4vpx (GitHub-reviewed advisory GHSA-4hjq-422q-4vpx lists affected ranges: Packagist mautic/core >=0 <3.3.2) Commands are suggestions: review each one before running it.
Loading voting…