Apache Superset Stored XSS on Dashboard markdown
CVE-2021-27907GHSA-w358-rj93-r5qv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-superset 0.38.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI apache-superset
- Affected
- <= 0.38.0
- Fixed in
- 0.38.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-w358-rj93-r5qv lists affected ranges: PyPI apache-superset >=0 <0.38.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w358-rj93-r5qv lists affected ranges: PyPI apache-superset >=0 <=0.38.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2021-27907: 86.39% estimated exploitation activity in the next 30 days; percentile 99.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Apache Superset up to and including 0.38.0 allowed the creation of a Markdown component on a Dashboard page for describing chart's related information. Abusing this functionality, a malicious user could inject javascript code executing unwanted action in the context of the user's browser. The javascript code will be automatically executed (Stored XSS) when a legitimate user surfs on the dashboard page. The vulnerability is exploitable creating a “div” section and embedding in it a “svg” element with javascript code.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-w358-rj93-r5qv
- Revision 1 · created ·
Published from osv record GHSA-w358-rj93-r5qv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-27907 Advisory: Apache Superset Stored XSS on Dashboard markdown IDs: CVE-2021-27907, GHSA-w358-rj93-r5qv Record: https://patchnext.com/advisories/cve-2021-27907 (revision 2, source checked 26 Oct 2026, 13:12 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: apache-superset 0.38.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI apache-superset: affected <= 0.38.0; fixed in 0.38.1 ## Suggested inspection (read-only) - `python -m pip show apache-superset`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on apache-superset. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-w358-rj93-r5qv (OSV record GHSA-w358-rj93-r5qv lists affected ranges: PyPI apache-superset >=0 <0.38.1 (fixed)) - Verified: https://github.com/advisories/GHSA-w358-rj93-r5qv (GitHub-reviewed advisory GHSA-w358-rj93-r5qv lists affected ranges: PyPI apache-superset >=0 <=0.38.0) Commands are suggestions: review each one before running it.
Loading voting…