Skip to content

← Actionable
Unrated

Remote code execution in Apache Tapestry

CVE-2021-27850GHSA-mj8x-cpr8-x39h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.tapestry:tapestry-core 5.7.1, 5.6.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2021-27850: 93.56% estimated exploitation activity in the next 30 days; percentile 99.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A critical unauthenticated remote code execution vulnerability was found all recent versions of Apache Tapestry. The affected versions include 5.4.5, 5.5.0, 5.6.2 and 5.7.0. The vulnerability I have found is a bypass of the fix for CVE-2019-0195. Recap: Before the fix of CVE-2019-0195 it was possible to download arbitrary class files from the classpath by providing a crafted asset file URL. An attacker was able to download the file AppModule.class by requesting the URL http://localhost:8080/assets/something/services/AppModule.class which contains a HMAC secret key. The fix for that bug was a blacklist filter that checks if the URL ends with .class, .properties or .xml. Bypass: Unfortunately, the blacklist solution can simply be bypassed by appending a / at the end of the URL: http://localhost:8080/assets/something/services/AppModule.class/ The slash is stripped after the blacklist check and the file AppModule.class is loaded into the response. This class usually contains the HMAC…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-mj8x-cpr8-x39h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-27850

Advisory: Remote code execution in Apache Tapestry
IDs: CVE-2021-27850, GHSA-mj8x-cpr8-x39h
Record: https://patchnext.com/advisories/cve-2021-27850 (revision 1, source checked 26 Oct 2026, 16:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.tapestry:tapestry-core 5.7.1, 5.6.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.tapestry:tapestry-core: affected >= 5.4.0, < 5.6.3; >= 5.7.0, < 5.7.1; fixed in 5.7.1, 5.6.3

## Suggested inspection (read-only)
- Maven org.apache.tapestry:tapestry-core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.tapestry:tapestry-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-mj8x-cpr8-x39h (GitHub-reviewed advisory GHSA-mj8x-cpr8-x39h lists affected ranges: Maven org.apache.tapestry:tapestry-core >=5.4.0 =5.7.0 <5.7.1)

Commands are suggestions: review each one before running it.

Loading voting…