Regular expression Denial of Service in @progfay/scrapbox-parser
CVE-2021-27405GHSA-9fhw-r42p-5c7r
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@progfay/scrapbox-parser 7.0.2, 6.0.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 6.0.3>= 7.0.0, < 7.0.2
- Fixed in
- 6.0.3, 7.0.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9fhw-r42p-5c7r lists affected ranges: npm @progfay/scrapbox-parser >=0 =7.0.0 <7.0.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9fhw-r42p-5c7r lists affected ranges: npm @progfay/scrapbox-parser >=0 =7.0.0 <7.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
- EPSS
- CVE-2021-27405: 1.76% estimated exploitation activity in the next 30 days; percentile 78.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A Regular expression Denial of Service flaw was found in the @progfay/scrapbox-parser package before 6.0.3, 7.0.2 for Node.js. The attacker that is able to be parsed a specially crafted text may cause the application to consume an excessive amount of CPU. Patches Upgrade to version 6.0.3, 7.0.2 or later. Workarounds Avoid to parse text with a lot of chars. References https://github.com/progfay/scrapbox-parser/pull/519 https://github.com/progfay/scrapbox-parser/pull/539 https://github.com/progfay/scrapbox-parser/pull/540 https://cve.mitre.org/cgi-bin/cvename.cgi?name=2021-27405 https://snyk.io/vuln/SNYK-JS-PROGFAYSCRAPBOXPARSER-1076803 For more information If you have any questions or comments about this advisory: Open an issue in github.com/progfay/scrapbox-parser
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-9fhw-r42p-5c7r
- Revision 1 · created ·
Published from osv record GHSA-9fhw-r42p-5c7r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-27405 Advisory: Regular expression Denial of Service in @progfay/scrapbox-parser IDs: CVE-2021-27405, GHSA-9fhw-r42p-5c7r Record: https://patchnext.com/advisories/cve-2021-27405 (revision 2, source checked 26 Oct 2026, 12:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @progfay/scrapbox-parser 7.0.2, 6.0.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @progfay/scrapbox-parser: affected < 6.0.3; >= 7.0.0, < 7.0.2; fixed in 6.0.3, 7.0.2 ## Suggested inspection (read-only) - `npm ls @progfay/scrapbox-parser --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @progfay/scrapbox-parser. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9fhw-r42p-5c7r (OSV record GHSA-9fhw-r42p-5c7r lists affected ranges: npm @progfay/scrapbox-parser >=0 =7.0.0 <7.0.2 (fixed)) - Verified: https://github.com/advisories/GHSA-9fhw-r42p-5c7r (GitHub-reviewed advisory GHSA-9fhw-r42p-5c7r lists affected ranges: npm @progfay/scrapbox-parser >=0 =7.0.0 <7.0.2) Commands are suggestions: review each one before running it.
Loading voting…