Command injection in samba-client
CVE-2021-27185GHSA-r3j7-x2g5-9gx6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (samba-client 4.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm samba-client
- Affected
- < 4.0.0
- Fixed in
- 4.0.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-r3j7-x2g5-9gx6 lists affected ranges: npm samba-client >=0 <4.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r3j7-x2g5-9gx6 lists affected ranges: npm samba-client >=0 <4.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2021-27185: 4.83% estimated exploitation activity in the next 30 days; percentile 92.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The samba-client package before 4.0.0 for Node.js allows command injection because of the use of process.exec.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-r3j7-x2g5-9gx6
- Revision 1 · created ·
Published from osv record GHSA-r3j7-x2g5-9gx6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-27185 Advisory: Command injection in samba-client IDs: CVE-2021-27185, GHSA-r3j7-x2g5-9gx6 Record: https://patchnext.com/advisories/cve-2021-27185 (revision 2, source checked 26 Oct 2026, 12:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: samba-client 4.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm samba-client: affected < 4.0.0; fixed in 4.0.0 ## Suggested inspection (read-only) - `npm ls samba-client --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on samba-client. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-r3j7-x2g5-9gx6 (OSV record GHSA-r3j7-x2g5-9gx6 lists affected ranges: npm samba-client >=0 <4.0.0 (fixed)) - Verified: https://github.com/advisories/GHSA-r3j7-x2g5-9gx6 (GitHub-reviewed advisory GHSA-r3j7-x2g5-9gx6 lists affected ranges: npm samba-client >=0 <4.0.0) Commands are suggestions: review each one before running it.
Loading voting…